summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/initng/initng-0.4.4.ebuild')
-rw-r--r--sys-apps/initng/initng-0.4.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/initng/initng-0.4.4.ebuild b/sys-apps/initng/initng-0.4.4.ebuild
new file mode 100644
index 000000000000..b4a18f34651b
--- /dev/null
+++ b/sys-apps/initng/initng-0.4.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/initng/initng-0.4.4.ebuild,v 1.1 2005/11/22 05:49:12 vapier Exp $
+
+DESCRIPTION="A next generation init replacement"
+HOMEPAGE="http://initng.thinktux.net/"
+SRC_URI="http://initng.thinktux.net/download/v${PV:0:3}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="debug"
+
+src_compile() {
+ econf \
+ --prefix=/ \
+ --with-splash \
+ $(use_enable debug) \
+ --with-doc-dir=/usr/share/doc/${PF} \
+ || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ # Dont need libtool linker scripts, so punt em
+ find "${D}" -name '*.la' -exec rm {} \;
+ # other packages install these
+ rm "${D}"/sbin/{{ifplugd,wpa_cli}.action} || die
+ dodoc README FAQ AUTHORS ChangeLog NEWS TEMPLATE_HEADER TODO
+}
+
+pkg_postinst() {
+ einfo "remember to add init=/sbin/initng in your grub or lilo config"
+ einfo "to use initng Happy testing."
+}