summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/netboot-base/netboot-base-20041006.ebuild')
-rw-r--r--sys-apps/netboot-base/netboot-base-20041006.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/sys-apps/netboot-base/netboot-base-20041006.ebuild b/sys-apps/netboot-base/netboot-base-20041006.ebuild
index b32a51315ffc..dd004ad8db90 100644
--- a/sys-apps/netboot-base/netboot-base-20041006.ebuild
+++ b/sys-apps/netboot-base/netboot-base-20041006.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/netboot-base/netboot-base-20041006.ebuild,v 1.1 2004/10/06 18:27:01 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/netboot-base/netboot-base-20041006.ebuild,v 1.2 2004/10/06 21:19:31 vapier Exp $
DESCRIPTION="Baselayout for netboot systems"
HOMEPAGE="http://www.gentoo.org/"
@@ -9,17 +9,25 @@ SRC_URI="http://dev.gentoo.org/~vapier/${P}.tar.bz2
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86"
-IUSE="netboot"
+KEYWORDS="arm hppa x86"
+IUSE=""
DEPEND=""
S=${WORKDIR}
pkg_setup() {
- use netboot || die "This is only for creating netboot images"
+ [ "${ROOT}" == "/" ] && die "refusing to emerge to /"
}
src_install() {
+ [ "${ROOT}" == "/" ] && die "refusing to install to /"
cp -r * ${D}/
}
+
+pkg_postinst() {
+ cd ${ROOT}
+ mkdir -p bin dev etc lib mnt proc sbin var
+ mkdir -p var/log
+ mkdir -p mnt/gentoo
+}