summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/sg3_utils/sg3_utils-1.27.ebuild')
-rw-r--r--sys-apps/sg3_utils/sg3_utils-1.27.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-apps/sg3_utils/sg3_utils-1.27.ebuild b/sys-apps/sg3_utils/sg3_utils-1.27.ebuild
new file mode 100644
index 000000000000..179d47877685
--- /dev/null
+++ b/sys-apps/sg3_utils/sg3_utils-1.27.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sg3_utils/sg3_utils-1.27.ebuild,v 1.1 2008/08/18 04:24:17 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Apps for querying the sg SCSI interface"
+HOMEPAGE="http://www.torque.net/sg/"
+SRC_URI="http://www.torque.net/sg/p/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-devel/libtool"
+RDEPEND="sys-apps/sdparm"
+PDEPEND=">=sys-apps/rescan-scsi-bus-1.24"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.26-stdint.patch
+ sed -i 's:libsgutils2:libsgutils:g' {lib,src}/Makefile.in || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed"
+ dodoc ChangeLog AUTHORS COVERAGE CREDITS README*
+ dodoc doc/README.doc examples/*.txt
+ newdoc scripts/README README.scripts
+ dosbin scripts/{scsi,sas}* || die
+}