summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/ucspi-unix/ucspi-unix-0.36-r3.ebuild')
-rw-r--r--sys-apps/ucspi-unix/ucspi-unix-0.36-r3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-apps/ucspi-unix/ucspi-unix-0.36-r3.ebuild b/sys-apps/ucspi-unix/ucspi-unix-0.36-r3.ebuild
new file mode 100644
index 000000000000..169b9cdba0ec
--- /dev/null
+++ b/sys-apps/ucspi-unix/ucspi-unix-0.36-r3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ucspi-unix/ucspi-unix-0.36-r3.ebuild,v 1.1 2008/11/07 13:44:38 bangert Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A ucspi implementation for unix sockets"
+HOMEPAGE="http://untroubled.org/ucspi-unix/"
+SRC_URI="http://untroubled.org/ucspi-unix/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/bglibs-1.019-r1"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-gentoo-head.patch
+ epatch "${FILESDIR}"/${P}-include-sys_socket.h.patch
+}
+
+src_compile() {
+ use kernel_linux && PEERCRED="-DHASPEERCRED=1"
+ echo "$(tc-getCC) ${CFLAGS} -I/usr/lib/bglibs/include ${PEERCRED} -D_GNU_SOURCE" > conf-cc
+ echo "$(tc-getCC) ${LDFLAGS} -L/usr/lib/bglibs/lib" > conf-ld
+ make || die #don't use emake b/c of jobserver
+}
+
+src_install() {
+ dobin unixserver unixclient unixcat || die
+ doman unixserver.1 unixclient.1
+ dodoc ANNOUNCEMENT NEWS PROTOCOL README TODO
+}