summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/util-linux/util-linux-2.19.ebuild')
-rw-r--r--sys-apps/util-linux/util-linux-2.19.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/sys-apps/util-linux/util-linux-2.19.ebuild b/sys-apps/util-linux/util-linux-2.19.ebuild
index 19cd55bd5d1f..63670a45502b 100644
--- a/sys-apps/util-linux/util-linux-2.19.ebuild
+++ b/sys-apps/util-linux/util-linux-2.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.19.ebuild,v 1.3 2011/04/07 01:09:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/util-linux/util-linux-2.19.ebuild,v 1.4 2011/04/07 05:18:20 vapier Exp $
EAPI="2"
@@ -24,14 +24,14 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+cramfs crypt nls old-linux perl selinux slang uclibc unicode"
+IUSE="+cramfs crypt ncurses nls old-linux perl selinux slang uclibc unicode"
RDEPEND="!sys-process/schedutils
!sys-apps/setarch
- >=sys-libs/ncurses-5.2-r2
!<sys-libs/e2fsprogs-libs-1.41.8
!<sys-fs/e2fsprogs-1.41.8
cramfs? ( sys-libs/zlib )
+ ncurses? ( >=sys-libs/ncurses-5.2-r2 )
perl? ( dev-lang/perl )
selinux? ( sys-libs/libselinux )
slang? ( sys-libs/slang )"
@@ -62,6 +62,7 @@ lfs_fallocate_test() {
rm -f "${T}"/fallocate.c
}
+usex() { use $1 && echo ${2:-yes} || echo ${3:-no} ; }
src_configure() {
lfs_fallocate_test
econf \
@@ -70,6 +71,7 @@ src_configure() {
--enable-agetty \
$(use_enable cramfs) \
$(use_enable old-linux elvtune) \
+ --with-ncurses=$(usex ncurses $(usex unicode auto yes) no) \
--disable-init \
--disable-kill \
--disable-last \
@@ -83,7 +85,6 @@ src_configure() {
--disable-wall \
--enable-write \
--without-pam \
- $(use unicode || echo --with-ncurses) \
$(use_with selinux) \
$(use_with slang) \
$(tc-has-tls || echo --disable-tls)