summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/hal/ChangeLog10
-rw-r--r--sys-apps/hal/hal-0.5.11-r6.ebuild (renamed from sys-apps/hal/hal-0.5.11-r5.ebuild)5
2 files changed, 11 insertions, 4 deletions
diff --git a/sys-apps/hal/ChangeLog b/sys-apps/hal/ChangeLog
index 00c3740fdfba..5c4ec1c5bb22 100644
--- a/sys-apps/hal/ChangeLog
+++ b/sys-apps/hal/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-apps/hal
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.261 2009/01/05 18:00:17 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/ChangeLog,v 1.262 2009/01/06 13:43:59 chainsaw Exp $
+
+*hal-0.5.11-r6 (06 Jan 2009)
+
+ 06 Jan 2009; <chainsaw@gentoo.org> -hal-0.5.11-r5.ebuild,
+ +hal-0.5.11-r6.ebuild:
+ Bad interactions between the ARM & PPC setup meant the PMU was
+ enabled/disabled twice. Avoid by using hardware variable instead of
+ use_enable for PMU.
*hal-0.5.11-r5 (05 Jan 2009)
diff --git a/sys-apps/hal/hal-0.5.11-r5.ebuild b/sys-apps/hal/hal-0.5.11-r6.ebuild
index f39fa890c93c..acc00a4f306c 100644
--- a/sys-apps/hal/hal-0.5.11-r5.ebuild
+++ b/sys-apps/hal/hal-0.5.11-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.11-r5.ebuild,v 1.1 2009/01/05 18:00:17 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hal/hal-0.5.11-r6.ebuild,v 1.1 2009/01/06 13:43:59 chainsaw Exp $
inherit eutils linux-info autotools flag-o-matic
@@ -166,7 +166,7 @@ src_compile() {
fi
hardware="--with-cpufreq --with-usb-csr --with-keymaps"
- use arm && hardware="$hardware --with-omap"
+ use arm && hardware="$hardware --with-omap --enable-pmu"
use ppc && hardware="$hardware --enable-pmu"
if use dell ; then
@@ -196,7 +196,6 @@ src_compile() {
--disable-acl-management \
--enable-pci \
$(use_enable apm) \
- $(use_enable arm pmu) \
$(use_enable debug verbose-mode) \
$(use_enable disk-partition parted) \
$(use_enable doc docbook-docs) \