summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/microcode-data/ChangeLog10
-rw-r--r--sys-apps/microcode-data/microcode-data-20130222.ebuild45
2 files changed, 53 insertions, 2 deletions
diff --git a/sys-apps/microcode-data/ChangeLog b/sys-apps/microcode-data/ChangeLog
index 7e6c595b0e48..ddcfec9468c8 100644
--- a/sys-apps/microcode-data/ChangeLog
+++ b/sys-apps/microcode-data/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-apps/microcode-data
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-data/ChangeLog,v 1.20 2012/09/23 08:15:03 phajdan.jr Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-data/ChangeLog,v 1.21 2013/04/27 07:59:37 vapier Exp $
+
+*microcode-data-20130222 (27 Apr 2013)
+
+ 27 Apr 2013; Mike Frysinger <vapier@gentoo.org>
+ +microcode-data-20130222.ebuild:
+ Version bump #440194 by Manuel Rüger.
23 Sep 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org>
microcode-data-20120606.ebuild:
diff --git a/sys-apps/microcode-data/microcode-data-20130222.ebuild b/sys-apps/microcode-data/microcode-data-20130222.ebuild
new file mode 100644
index 000000000000..276fbd51624e
--- /dev/null
+++ b/sys-apps/microcode-data/microcode-data-20130222.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/microcode-data/microcode-data-20130222.ebuild,v 1.1 2013/04/27 07:59:37 vapier Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+# Find updates by searching and clicking the first link (hopefully it's the one):
+# http://www.intel.com/content/www/us/en/search.html?keyword=Processor+Microcode+Data+File
+
+NUM="22508"
+DESCRIPTION="Intel IA32 microcode update data"
+HOMEPAGE="http://urbanmyth.org/microcode/ https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=${NUM}"
+SRC_URI="http://downloadmirror.intel.com/${NUM}/eng/microcode-${PV}.tgz"
+
+LICENSE="intel-ucode"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!<sys-apps/microcode-ctl-1.17-r2" #268586
+
+S=${WORKDIR}
+
+src_unpack() {
+ default
+ cp "${FILESDIR}"/intel-microcode2ucode.c ./ || die
+}
+
+src_compile() {
+ tc-env_build emake intel-microcode2ucode
+ ./intel-microcode2ucode microcode.dat || die
+}
+
+src_install() {
+ insinto /lib/firmware
+ doins -r microcode.dat intel-ucode
+}
+
+pkg_postinst() {
+ elog "The microcode available for Intel CPUs has been updated. You'll need"
+ elog "to reload the code into your processor. If you're using the init.d:"
+ elog "/etc/init.d/microcode_ctl restart"
+}