summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/nss-mdns')
-rw-r--r--sys-auth/nss-mdns/ChangeLog8
-rw-r--r--sys-auth/nss-mdns/files/digest-nss-mdns-0.83
-rw-r--r--sys-auth/nss-mdns/nss-mdns-0.8.ebuild51
3 files changed, 61 insertions, 1 deletions
diff --git a/sys-auth/nss-mdns/ChangeLog b/sys-auth/nss-mdns/ChangeLog
index 05b326cdf8cf..78111a04b310 100644
--- a/sys-auth/nss-mdns/ChangeLog
+++ b/sys-auth/nss-mdns/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/nss-mdns
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-mdns/ChangeLog,v 1.3 2006/03/01 23:14:02 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-mdns/ChangeLog,v 1.4 2006/05/02 01:11:13 compnerd Exp $
+
+*nss-mdns-0.8 (02 May 2006)
+
+ 02 May 2006; Saleem Abdulrasool <compnerd@gentoo.org>
+ +nss-mdns-0.8.ebuild:
+ Version bump from upstream
01 Mar 2006; Saleem Abdulrasool <compnerd@gentoo.org> nss-mdns-0.7.ebuild:
Changing sleep to epause (bug #124322)
diff --git a/sys-auth/nss-mdns/files/digest-nss-mdns-0.8 b/sys-auth/nss-mdns/files/digest-nss-mdns-0.8
new file mode 100644
index 000000000000..bef767a68856
--- /dev/null
+++ b/sys-auth/nss-mdns/files/digest-nss-mdns-0.8
@@ -0,0 +1,3 @@
+MD5 d7545fbf6df15f3af502531efcf15a25 nss-mdns-0.8.tar.gz 342256
+RMD160 08b361275e68c7623ba41d304867178ae6a0301f nss-mdns-0.8.tar.gz 342256
+SHA256 280212222924155627aea4ac2eb57073b8aa78a831b177fcae46de1ac211715a nss-mdns-0.8.tar.gz 342256
diff --git a/sys-auth/nss-mdns/nss-mdns-0.8.ebuild b/sys-auth/nss-mdns/nss-mdns-0.8.ebuild
new file mode 100644
index 000000000000..c41e5de8a723
--- /dev/null
+++ b/sys-auth/nss-mdns/nss-mdns-0.8.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/nss-mdns/nss-mdns-0.8.ebuild,v 1.1 2006/05/02 01:11:13 compnerd Exp $
+
+inherit eutils
+
+DESCRIPTION="Name Service Switch module for Multicast DNS"
+HOMEPAGE="http://0pointer.de/lennart/projects/nss-mdns/"
+SRC_URI="http://0pointer.de/lennart/projects/nss-mdns/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="avahi"
+
+DEPEND="avahi? ( net-dns/avahi )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf $(use_enable avahi) || die "configure failed"
+ emake || die "compile failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "install failed"
+
+ insinto /etc
+ doins ${FILESDIR}/mdns.allow
+
+ dodoc README
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "You must modify your name service switch look up file to enable"
+ ewarn "multicast DNS lookups. If you wish to resolve only IPv6 addresses"
+ ewarn "use mdns6. For IPv4 addresses only, use mdns4. To resolve both"
+ ewarn "use mdns2. Keep in mind that mdns2 will be slower if there are no"
+ ewarn "IPv6 addresses on the network. There are minimal (mdns?_minimal)"
+ ewarn "for slightly faster resolution which do not wait for timeouts."
+ ewarn
+ ewarn "Add the appropriate mdns into the hosts line in /etc/nsswitch.conf"
+ ewarn "An example line looks like:"
+ einfo "hosts: files mdns4 dns"
+ ewarn
+ ewarn "Add any domains other than those ending in .local to"
+ ewarn "/etc/mdns.allow"
+ ewarn
+ ebeep 5
+ epause 10
+}