summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/pam_pwdfile/pam_pwdfile-0.99.ebuild')
-rw-r--r--sys-auth/pam_pwdfile/pam_pwdfile-0.99.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/sys-auth/pam_pwdfile/pam_pwdfile-0.99.ebuild b/sys-auth/pam_pwdfile/pam_pwdfile-0.99.ebuild
index c6dfd1787a64..889658a1dc09 100644
--- a/sys-auth/pam_pwdfile/pam_pwdfile-0.99.ebuild
+++ b/sys-auth/pam_pwdfile/pam_pwdfile-0.99.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_pwdfile/pam_pwdfile-0.99.ebuild,v 1.4 2006/10/15 14:25:51 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/pam_pwdfile/pam_pwdfile-0.99.ebuild,v 1.5 2007/11/04 15:38:35 flameeyes Exp $
-inherit flag-o-matic
+inherit flag-o-matic pam
DESCRIPTION="PAM module for authenticating against passwd-like files."
HOMEPAGE="http://cpbotha.net/pam_pwdfile.html"
@@ -17,11 +17,10 @@ src_compile() {
# the upstream makefile does CFLAGS in a horrible way
# that '-c' is 100% required here
append-flags -fPIC -Wall -Wformat-security -D_BSD_SOURCE -c
- emake -f contrib/Makefile.standalone CFLAGS="${CFLAGS}"
+ emake -f contrib/Makefile.standalone CFLAGS="${CFLAGS}" || die "emake failed"
}
src_install() {
- exeinto /lib/security
- doexe ${PN}.so
+ dopammod ${PN}.so
dodoc INSTALL README changelog contrib/warwick_duncan-cyrus_without_system_accounts.txt
}