summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth')
-rw-r--r--sys-auth/tcb/ChangeLog9
-rw-r--r--sys-auth/tcb/tcb-1.0.3.ebuild51
2 files changed, 58 insertions, 2 deletions
diff --git a/sys-auth/tcb/ChangeLog b/sys-auth/tcb/ChangeLog
index 8c207691ef57..3a2a0df92e88 100644
--- a/sys-auth/tcb/ChangeLog
+++ b/sys-auth/tcb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-auth/tcb
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/tcb/ChangeLog,v 1.2 2008/03/30 20:13:52 swegener Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/tcb/ChangeLog,v 1.3 2009/12/29 11:03:39 phajdan.jr Exp $
+
+*tcb-1.0.3 (29 Dec 2009)
+
+ 29 Dec 2009; Pawel Hajdan jr <phajdan.jr@gentoo.org> +tcb-1.0.3.ebuild:
+ Version bump, bug #298509.
27 Mar 2008; Diego Pettenò <flameeyes@gentoo.org>
+files/tcb-1.0.2-build.patch, +files/tcb-1.0-build.patch, +metadata.xml,
diff --git a/sys-auth/tcb/tcb-1.0.3.ebuild b/sys-auth/tcb/tcb-1.0.3.ebuild
new file mode 100644
index 000000000000..72a767941204
--- /dev/null
+++ b/sys-auth/tcb/tcb-1.0.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/tcb/tcb-1.0.3.ebuild,v 1.1 2009/12/29 11:03:39 phajdan.jr Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="Libraries and tools implementing the tcb password shadowing scheme"
+HOMEPAGE="http://www.openwall.com/tcb/"
+SRC_URI="ftp://ftp.openwall.com/pub/projects/tcb/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="pam"
+
+DEPEND="pam? ( >=sys-libs/pam-0.75 )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ for group in auth chkpwd shadow ; do
+ enewgroup ${group}
+ done
+
+ mymakeopts="
+ SLIBDIR=/$(get_libdir)
+ LIBDIR=/usr/$(get_libdir)
+ MANDIR=/usr/share/man
+ DESTDIR='${D}'"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-1.0.2-build.patch
+ use pam || sed -i '/pam/d' Makefile
+}
+
+src_compile() {
+ emake $mymakeopts || die "emake failed"
+}
+
+src_install() {
+ emake $mymakeopts install || die "emake install failed"
+ dodoc ChangeLog
+}
+
+pkg_postinst() {
+ einfo "You must now run /sbin/tcb_convert to convert your shadow to tcb"
+ einfo "To remove this you must first run /sbin/tcp_unconvert and then unmerge"
+}