summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/ocfs/ocfs-1.0.14.ebuild')
-rw-r--r--sys-cluster/ocfs/ocfs-1.0.14.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/sys-cluster/ocfs/ocfs-1.0.14.ebuild b/sys-cluster/ocfs/ocfs-1.0.14.ebuild
new file mode 100644
index 000000000000..542d3b453ede
--- /dev/null
+++ b/sys-cluster/ocfs/ocfs-1.0.14.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ocfs/ocfs-1.0.14.ebuild,v 1.1 2005/03/10 14:39:40 xmerlin Exp $
+
+inherit linux-mod
+
+DESCRIPTION="The Oracle Cluster Filesystem"
+SRC_URI="http://oss.oracle.com/projects/ocfs/dist/files/source/${P}.tar.gz"
+HOMEPAGE="http://oss.oracle.com/projects/ocfs"
+LICENSE="GPL-2"
+
+DEPEND="virtual/linux-sources"
+
+IUSE="aio"
+SLOT="0"
+KEYWORDS="~x86"
+
+pkg_setup() {
+ if kernel_is 2 6; then
+ die "${P} supports only 2.4 kernels"
+ fi
+}
+
+src_compile() {
+ check_KV
+ set_arch_to_kernel
+
+ local myconf
+ use aio && myconf="--enable-aio=yes" || myconf="--enable-aio=no"
+
+ econf \
+ --with-kernel=${KERNEL_DIR} \
+ ${myconf} \
+ || die
+
+ emake || die
+}
+
+src_install() {
+ einstall DESTDIR=${D} || die "Failed to install"
+
+ dodir /etc/ocfs
+ insinto /etc/ocfs
+ doins ocfs2/ocfs.conf
+
+ dodoc README docs/ocfs_doc.zip || die
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ einfo ""
+ einfo "Please remember to re-emerge ${PN} when you upgrade your kernel!"
+ einfo ""
+ einfo "Please edit the configuration file /etc/ocfs/ocfs.conf"
+ einfo ""
+}