summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/autoconf-wrapper/autoconf-wrapper-9-r1.ebuild')
-rw-r--r--sys-devel/autoconf-wrapper/autoconf-wrapper-9-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-devel/autoconf-wrapper/autoconf-wrapper-9-r1.ebuild b/sys-devel/autoconf-wrapper/autoconf-wrapper-9-r1.ebuild
new file mode 100644
index 000000000000..07ceefa85f9c
--- /dev/null
+++ b/sys-devel/autoconf-wrapper/autoconf-wrapper-9-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf-wrapper/autoconf-wrapper-9-r1.ebuild,v 1.1 2010/08/06 23:05:43 flameeyes Exp $
+
+inherit multilib
+
+DESCRIPTION="wrapper for autoconf to manage multiple autoconf versions"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+S=${WORKDIR}
+
+SUPPORTED_AC_VERSIONS="2.67:2.5 2.66:2.5 2.65:2.5 2.64:2.5 2.63:2.5 2.62:2.5 2.61:2.5 2.60:2.5 2.59:2.5 2.13:2.1"
+
+src_compile() {
+ sed -e "/vers=/s|\".*\"|\"${SUPPORTED_AC_VERSIONS}\"|" \
+ "${FILESDIR}"/ac-wrapper-${PV}.sh \
+ > "${T}"/ac-wrapper.sh \
+ || die "ac-wrapper sed failed"
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/misc
+ doexe "${T}"/ac-wrapper.sh || die
+
+ dodir /usr/bin
+ local x=
+ for x in auto{conf,header,m4te,reconf,scan,update} ifnames ; do
+ dosym ../$(get_libdir)/misc/ac-wrapper.sh /usr/bin/${x} || die
+ done
+}