summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/automake/automake-1.14.1.ebuild')
-rw-r--r--sys-devel/automake/automake-1.14.1.ebuild23
1 files changed, 13 insertions, 10 deletions
diff --git a/sys-devel/automake/automake-1.14.1.ebuild b/sys-devel/automake/automake-1.14.1.ebuild
index 56e0fe2c1888..7dce3abfa4d1 100644
--- a/sys-devel/automake/automake-1.14.1.ebuild
+++ b/sys-devel/automake/automake-1.14.1.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.14.1.ebuild,v 1.3 2014/01/17 04:23:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.14.1.ebuild,v 1.4 2014/11/15 06:07:49 vapier Exp $
-inherit eutils versionator unpacker
+EAPI="4"
+
+inherit eutils versionator
if [[ ${PV/_beta} == ${PV} ]]; then
MY_P=${P}
@@ -27,26 +29,27 @@ IUSE=""
RDEPEND="dev-lang/perl
>=sys-devel/automake-wrapper-9
- >=sys-devel/autoconf-2.62
+ >=sys-devel/autoconf-2.69
sys-devel/gnuconfig"
DEPEND="${RDEPEND}
sys-apps/help2man"
S="${WORKDIR}/${MY_P}"
-src_unpack() {
- unpacker_src_unpack
- cd "${S}"
+src_prepare() {
export WANT_AUTOCONF=2.5
}
+src_configure() {
+ econf --docdir=/usr/share/doc/${PF} HELP2MAN=true
+}
+
src_compile() {
- econf --docdir=/usr/share/doc/${PF} HELP2MAN=true || die
- emake APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}" || die
+ emake APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
}
src_test() {
- emake check || die
+ emake check
}
# slot the info pages. do this w/out munging the source so we don't have
@@ -80,7 +83,7 @@ slot_info_pages() {
src_install() {
emake DESTDIR="${D}" install \
- APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}" || die
+ APIVERSION="${SLOT}" pkgvdatadir="/usr/share/${PN}-${SLOT}"
slot_info_pages
rm "${D}"/usr/share/aclocal/README || die
rmdir "${D}"/usr/share/aclocal || die