summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/quota/ChangeLog8
-rw-r--r--sys-fs/quota/files/quota-3.06-no-stripping.patch11
-rw-r--r--sys-fs/quota/quota-3.12-r1.ebuild29
3 files changed, 33 insertions, 15 deletions
diff --git a/sys-fs/quota/ChangeLog b/sys-fs/quota/ChangeLog
index 18e90ea2fde1..0e56b9038530 100644
--- a/sys-fs/quota/ChangeLog
+++ b/sys-fs/quota/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/quota
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/ChangeLog,v 1.8 2005/03/19 10:48:06 kloeri Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/ChangeLog,v 1.9 2005/06/03 23:06:13 vapier Exp $
+
+ 03 Jun 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/quota-3.06-no-stripping.patch, quota-3.12-r1.ebuild:
+ Touchups and dont strip binaries with `install`.
19 Mar 2005; Bryan Østergaard <kloeri@gentoo.org> quota-3.12.ebuild:
Stable on alpha.
diff --git a/sys-fs/quota/files/quota-3.06-no-stripping.patch b/sys-fs/quota/files/quota-3.06-no-stripping.patch
new file mode 100644
index 000000000000..0ab5385a454b
--- /dev/null
+++ b/sys-fs/quota/files/quota-3.06-no-stripping.patch
@@ -0,0 +1,11 @@
+--- quota-tools/Makefile.in
++++ quota-tools/Makefile.in
+@@ -90,6 +90,6 @@
+ -$(INSTALL) -m 755 -d $(ROOTDIR)$(includedir)/rpcsvc
+ -$(INSTALL) -m 644 rquota.h rquota.x $(ROOTDIR)$(includedir)/rpcsvc
+- -$(INSTALL) -s -m $(DEF_SBIN_MODE) quota $(ROOTDIR)$(bindir)
+- -$(INSTALL) -s -m $(DEF_SBIN_MODE) rpc.rquotad $(ROOTDIR)$(sbindir)
++ -$(INSTALL) -m $(DEF_SBIN_MODE) quota $(ROOTDIR)$(bindir)
++ -$(INSTALL) -m $(DEF_SBIN_MODE) rpc.rquotad $(ROOTDIR)$(sbindir)
+ -$(INSTALL) -m $(DEF_MAN_MODE) *.1 $(ROOTDIR)$(mandir)/man1
+ -$(INSTALL) -m $(DEF_MAN_MODE) *.2 $(ROOTDIR)$(mandir)/man2
diff --git a/sys-fs/quota/quota-3.12-r1.ebuild b/sys-fs/quota/quota-3.12-r1.ebuild
index 52c1dcdd8cae..6201b8992b0e 100644
--- a/sys-fs/quota/quota-3.12-r1.ebuild
+++ b/sys-fs/quota/quota-3.12-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/quota-3.12-r1.ebuild,v 1.1 2005/01/07 13:04:51 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/quota/quota-3.12-r1.ebuild,v 1.2 2005/06/03 23:06:13 vapier Exp $
inherit eutils
@@ -13,8 +13,7 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
IUSE="nls tcpd ldap rpc"
-RDEPEND="virtual/libc
- ldap? ( net-nds/openldap )
+RDEPEND="ldap? ( net-nds/openldap )
tcpd? ( sys-apps/tcp-wrappers )
rpc? ( net-nds/portmap )"
DEPEND="${RDEPEND}
@@ -24,25 +23,30 @@ S=${WORKDIR}/quota-tools
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# patch to prevent quotactl.2 manpage from being installed
# that page is provided by man-pages instead
- epatch ${FILESDIR}/${PN}-no-quotactl-manpage.patch
+ epatch "${FILESDIR}"/${PN}-no-quotactl-manpage.patch
+
+ # Don't strip binaries (from Fedora)
+ epatch "${FILESDIR}"/quota-3.06-no-stripping.patch
sed -i -e "s:,LIBS=\"\$saved_LIBS=\":;LIBS=\"\$saved_LIBS\":" configure
}
src_compile() {
- local myconf
- myconf="$(use_enable nls) $(use_enable ldap ldapmail)"
- myconf="${myconf} $(use_enable rpc) $(use_enable rpc rpcsetquota)"
- econf ${myconf} || die
+ econf \
+ $(use_enable nls) \
+ $(use_enable ldap ldapmail) \
+ $(use_enable rpc) \
+ $(use_enable rpc rpcsetquota) \
+ || die
emake || die
}
src_install() {
- dodir {sbin,etc,usr/sbin,usr/bin,usr/share/man/man{1,3,8}}
+ dodir /{sbin,etc,usr/sbin,usr/bin,usr/share/man/man{1,3,8}}
make ROOTDIR="${D}" install || die
rm -r "${D}"/usr/include #70938
@@ -54,10 +58,9 @@ src_install() {
dodoc README.*
dodoc Changelog
- newinitd ${FILESDIR}/quota.rc6 quota
+ newinitd "${FILESDIR}"/quota.rc6 quota
- if use ldap
- then
+ if use ldap ; then
insinto /etc/openldap/schema
insopts -m0644
doins ldap-scripts/quota.schema