summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/hardened-sources/hardened-sources-2.4.20.ebuild')
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.4.20.ebuild25
1 files changed, 12 insertions, 13 deletions
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.4.20.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.4.20.ebuild
index 196959c56b78..8938caa62e14 100644
--- a/sys-kernel/hardened-sources/hardened-sources-2.4.20.ebuild
+++ b/sys-kernel/hardened-sources/hardened-sources-2.4.20.ebuild
@@ -17,8 +17,8 @@ EXTRAVERSION=-hardened
KV=${OKV}${EXTRAVERSION}
S=${WORKDIR}/linux-${KV}
DESCRIPTION="Special Security Hardened Gentoo Kernel (don't use this yet, it isn't ready)"
-SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
- http://www.citi.umich.edu/u/provos/systrace/systrace-linux-2.4.20-v1.2.diff"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://gentoo/patches-${KV}.tar.bz2"
HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/hardened/"
@@ -26,18 +26,17 @@ KEYWORDS="~x86"
SLOT="${KV}"
src_unpack() {
- unpack linux-${OKV}.tar.bz2
+ unpack linux-${OKV}.tar.bz2 patches-${KV}.tar.bz2
mv linux-${OKV} linux-${KV} || die
- cd ${S}
- patch -p1 < ${DISTDIR}/${KPATCH} || die "Cannot find systrace patch"
+
+ cd ${KV}
+ kernel_src_unpack
}
-src_compile() {
- einfo "You must compile and install this kernel *before* you can emerge and use the systrace userland utilities."
-}
-
-src_install() {
- dodir /usr/src
- echo ">>> Copying sources..."
- mv ${WORKDIR}/linux-${KV} ${D}/usr/src
+pkg_postinst() {
+ kernel_pkg_postinst
+ einfo "This kernel contains LSM, GRSec2, and Systrace"
+ einfo "This is not yet a production ready kernel. If you experience problems with"
+ einfo "this kernel please report them by assigning bugs on bugs.gentoo.org to"
+ einfo "frogger@gentoo.org"
}