summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/hppa-sources/hppa-sources-2.6.13_p1.ebuild')
-rw-r--r--sys-kernel/hppa-sources/hppa-sources-2.6.13_p1.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/sys-kernel/hppa-sources/hppa-sources-2.6.13_p1.ebuild b/sys-kernel/hppa-sources/hppa-sources-2.6.13_p1.ebuild
deleted file mode 100644
index 09b90583afeb..000000000000
--- a/sys-kernel/hppa-sources/hppa-sources-2.6.13_p1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hppa-sources/hppa-sources-2.6.13_p1.ebuild,v 1.1 2005/09/05 18:16:09 gmsoft Exp $
-
-ETYPE="sources"
-
-CKV="${PV/_*}"
-K_NOUSENAME=true
-inherit kernel-2
-
-KV_FULL=${CKV}-pa${PATCH_LEVEL}
-detect_version
-
-
-DESCRIPTION="Full sources for the Linux kernel with patch for hppa"
-PATCH_LEVEL="${PV/${CKV}_p/}"
-SRC_URI="${KERNEL_URI}
-http://ftp.parisc-linux.org/cvs/linux-2.6/patch-${OKV}-pa${PATCH_LEVEL}.gz
-http://dev.gentoo.org/~dertobi123/hppa/4705_squashfs-2.1.patch.bz2"
-UNIPATCH_LIST="${T}/patch-${OKV}-pa${PATCH_LEVEL}.patch
-${DISTDIR}/4705_squashfs-2.1.patch.bz2"
-HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/ http://parisc-linux.org"
-KEYWORDS="-* ~hppa"
-
-
-src_unpack() {
-
- if [[ -n ${KV_EXTRA} ]]
- then
-
- KV_EXTRA=".${KV_EXTRA}"
-
- zcat ${DISTDIR}/patch-${OKV}-pa${PATCH_LEVEL}.gz | \
- sed -e "/+EXTRAVERSION/s/=.*\$/=/" > \
- ${T}/patch-${OKV}-pa${PATCH_LEVEL}.patch
- else
- zcat ${DISTDIR}/patch-${OKV}-pa${PATCH_LEVEL}.gz > \
- ${T}/patch-${OKV}-pa${PATCH_LEVEL}.patch
- fi
-
- EXTRAVERSION=${KV_EXTRA}-pa${PATCH_LEVEL}
-
- universal_unpack
-
-
- # We force the order of patching. kernel-2.eclass does weird stuff
- unipatch ${UNIPATCH_LIST}
- unipatch ${UNIPATCH_LIST_DEFAULT}
-
- unpack_set_extraversion
- unpack_fix_docbook
- unpack_fix_install_path
-
-}