summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/linux-headers/linux-headers-2.4.21.ebuild')
-rw-r--r--sys-kernel/linux-headers/linux-headers-2.4.21.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/sys-kernel/linux-headers/linux-headers-2.4.21.ebuild b/sys-kernel/linux-headers/linux-headers-2.4.21.ebuild
index f96541febff2..16d7e684aecd 100644
--- a/sys-kernel/linux-headers/linux-headers-2.4.21.ebuild
+++ b/sys-kernel/linux-headers/linux-headers-2.4.21.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.4.21.ebuild,v 1.6 2003/09/20 04:18:26 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.4.21.ebuild,v 1.7 2003/09/21 05:18:54 kumba Exp $
ETYPE="headers"
inherit kernel
OKV=${PV/_/-}
S=${WORKDIR}/linux-${OKV}
+EXTRAVERSION=""
# What's in this kernel?
@@ -22,7 +23,7 @@ SLOT="${OKV}"
KEYWORDS="-* amd64 ~sparc"
-# Figure out what architecture we are, and set KERNEL_ARCH appropriately
+# Figure out what architecture we are, and set ARCH appropriately
ARCH="${ARCH:-`uname -m`}"
ARCH=`echo $ARCH | sed -e s/[i].86/i386/ -e s/x86/i386/ -e s/sun4u/sparc64/ -e s/arm.*/arm/ -e s/sa110/arm/ -e s/amd64/x86_64/`
[ "$ARCH" == "sparc" -a "$PROFILE_ARCH" == "sparc64" ] && ARCH=sparc64
@@ -43,7 +44,8 @@ src_unpack() {
cd ${S}
# Big Endian architectures need this patch in order to build certain programs properly
- # Right now, this fix only affects sparc. hppa and ppc will need to edit this later.
+ # Right now, this fix only affects sparc. Other big-endian archs will need to edit this if they need it.
+ # Issue will be fixed in 2.4.23+ kernel series (issue has been fixed in 2.6.0).
# Closes Bug #26062
if [ -n "`use sparc`" ]; then
epatch ${FILESDIR}/bigendian-byteorder-fix.patch
@@ -58,7 +60,7 @@ src_compile() {
# Do normal src_compile stuff
kernel_src_compile
- # If this is sparc, then geneate asm_offsets.h
+ # If this is sparc, then generate asm_offsets.h
if [ -n "`use sparc`" ]; then
make dep ARCH=sparc || die "Failed to run 'make dep'"
fi
@@ -83,7 +85,7 @@ src_install() {
cp -ax ${S}/include/asm-sparc/* ${D}/usr/include/asm-sparc
# If this is sparc64, then we need asm-sparc64 stuff too
- if [ "$PROFILE_ARCH" = "sparc64" ]; then
+ if [ "${PROFILE_ARCH}" = "sparc64" ]; then
dodir /usr/include/asm-sparc64
cp -ax ${S}/include/asm-sparc64/* ${D}/usr/include/asm-sparc64
fi