summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/tuxonice-sources/tuxonice-sources-3.4.71.ebuild')
-rw-r--r--sys-kernel/tuxonice-sources/tuxonice-sources-3.4.71.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-kernel/tuxonice-sources/tuxonice-sources-3.4.71.ebuild b/sys-kernel/tuxonice-sources/tuxonice-sources-3.4.71.ebuild
new file mode 100644
index 000000000000..4963fbd934f3
--- /dev/null
+++ b/sys-kernel/tuxonice-sources/tuxonice-sources-3.4.71.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/tuxonice-sources/tuxonice-sources-3.4.71.ebuild,v 1.1 2013/12/01 23:49:40 floppym Exp $
+
+EAPI="5"
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="52"
+
+inherit kernel-2
+detect_version
+detect_arch
+
+DESCRIPTION="TuxOnIce + Gentoo patchset sources"
+HOMEPAGE="http://dev.gentoo.org/~mpagano/genpatches/ http://www.tuxonice.net"
+
+TUXONICE_SNAPSHOT="2013-11-30"
+
+TUXONICE_PATCH="tuxonice-for-linux-${PV}-${TUXONICE_SNAPSHOT}.patch.bz2"
+TUXONICE_URI="http://tuxonice.net/downloads/all/${TUXONICE_PATCH}"
+UNIPATCH_LIST="${DISTDIR}/${TUXONICE_PATCH}"
+UNIPATCH_STRICTORDER="yes"
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${TUXONICE_URI}"
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="${RDEPEND}
+ >=sys-apps/tuxonice-userui-1.0
+ || ( >=sys-power/hibernate-script-2.0 sys-power/pm-utils )"
+
+K_EXTRAELOG="If there are issues with this kernel, please direct any
+ queries to the tuxonice-users mailing list:
+ http://lists.tuxonice.net/mailman/listinfo/tuxonice-users/"
+K_SECURITY_UNSUPPORTED="1"