summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/glibc/glibc-2.3.6-r2.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.3.6-r2.ebuild24
1 files changed, 14 insertions, 10 deletions
diff --git a/sys-libs/glibc/glibc-2.3.6-r2.ebuild b/sys-libs/glibc/glibc-2.3.6-r2.ebuild
index 90d2e166966c..740018fd239d 100644
--- a/sys-libs/glibc/glibc-2.3.6-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.3.6-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r2.ebuild,v 1.6 2006/01/13 12:15:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r2.ebuild,v 1.7 2006/01/14 20:12:20 vapier Exp $
# TODO:
# - fix warning from glibc build system:
@@ -1276,16 +1276,20 @@ src_strip() {
# prepallstrip
pushd "${D}" > /dev/null
- mkdir -p "${T}"/strip-backup
- for x in $(find "${D}" -maxdepth 3 \
- '(' -name 'ld-*' -o -name 'libpthread*' -o -name 'libthread_db*' ')' \
- -a '(' '!' -name '*.a' ')' -type f -printf '%P ')
- do
- mkdir -p "${T}/strip-backup/${x%/*}"
- cp -a -- "${D}/${x}" "${T}/strip-backup/${x}" || die "backing up ${x}"
- done
+ if ! is_crosscompile ; then
+ mkdir -p "${T}"/strip-backup
+ for x in $(find "${D}" -maxdepth 3 \
+ '(' -name 'ld-*' -o -name 'libpthread*' -o -name 'libthread_db*' ')' \
+ -a '(' '!' -name '*.a' ')' -type f -printf '%P ')
+ do
+ mkdir -p "${T}/strip-backup/${x%/*}"
+ cp -a -- "${D}/${x}" "${T}/strip-backup/${x}" || die "backing up ${x}"
+ done
+ fi
env -uRESTRICT CHOST=${CTARGET} prepallstrip
- cp -a -- "${T}"/strip-backup/* "${D}"/ || die "restoring non-stripped libs"
+ if ! is_crosscompile ; then
+ cp -a -- "${T}"/strip-backup/* "${D}"/ || die "restoring non-stripped libs"
+ fi
popd > /dev/null
}