summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libstatgrab/libstatgrab-0.17.ebuild')
-rw-r--r--sys-libs/libstatgrab/libstatgrab-0.17.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-libs/libstatgrab/libstatgrab-0.17.ebuild b/sys-libs/libstatgrab/libstatgrab-0.17.ebuild
new file mode 100644
index 000000000000..6072a7b16588
--- /dev/null
+++ b/sys-libs/libstatgrab/libstatgrab-0.17.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstatgrab/libstatgrab-0.17.ebuild,v 1.1 2012/02/14 21:23:45 radhermit Exp $
+
+EAPI=4
+
+inherit autotools-utils
+
+DESCRIPTION="A tool to provide access to statistics about the system on which it's run."
+HOMEPAGE="http://www.i-scream.org/libstatgrab/"
+SRC_URI="http://www.mirrorservice.org/sites/ftp.i-scream.org/pub/i-scream/libstatgrab/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 LGPL-2.1 )"
+SLOT=0
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE="static-libs"
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}"
+
+DOCS=( ChangeLog PLATFORMS NEWS AUTHORS README )
+
+src_configure() {
+ local myeconfargs=(
+ --disable-setgid-binaries
+ --disable-setuid-binaries
+ --disable-deprecated
+ --with-ncurses
+ $(use_enable static-libs static)
+ )
+ autotools-utils_src_configure
+}