summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/talloc/ChangeLog9
-rw-r--r--sys-libs/talloc/files/talloc-2.0.0-without-doc.patch21
-rw-r--r--sys-libs/talloc/talloc-2.0.0-r1.ebuild55
3 files changed, 84 insertions, 1 deletions
diff --git a/sys-libs/talloc/ChangeLog b/sys-libs/talloc/ChangeLog
index de8eeb30c4ee..b8deea6153b0 100644
--- a/sys-libs/talloc/ChangeLog
+++ b/sys-libs/talloc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-libs/talloc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/talloc/ChangeLog,v 1.3 2009/10/11 12:03:00 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/talloc/ChangeLog,v 1.4 2009/10/23 16:27:11 patrick Exp $
+
+*talloc-2.0.0-r1 (23 Oct 2009)
+
+ 23 Oct 2009; Patrick Lauer <patrick@gentoo.org> +talloc-2.0.0-r1.ebuild,
+ +files/talloc-2.0.0-without-doc.patch:
+ Ebuild cleanups thanks to pva, bug #288536, making docs optional #290193,
+ thanks to Andrew Church for the patch
11 Oct 2009; Petteri Räty <betelgeuse@gentoo.org> talloc-2.0.0.ebuild:
Block <net-fs/samba-libs-3.4 for bug #288545.
diff --git a/sys-libs/talloc/files/talloc-2.0.0-without-doc.patch b/sys-libs/talloc/files/talloc-2.0.0-without-doc.patch
new file mode 100644
index 000000000000..1e9a319dc753
--- /dev/null
+++ b/sys-libs/talloc/files/talloc-2.0.0-without-doc.patch
@@ -0,0 +1,21 @@
+--- talloc-2.0.0-orig/configure.ac 2009-08-31 02:58:36 +0900
++++ talloc-2.0.0/configure.ac 2009-10-23 11:00:13 +0900
+@@ -36,10 +36,15 @@
+ m4_include(libtalloc.m4)
+ m4_include(compat/talloc_compat1.m4)
+
+-AC_PATH_PROG(XSLTPROC,xsltproc)
+ DOC_TARGET=""
+-if test -n "$XSLTPROC"; then
+- DOC_TARGET=doc
++AC_ARG_WITH([doc],
++ AS_HELP_STRING([--without-doc], [disable manpage generation]),
++ [], [with_doc=yes])
++if test "yes" = "$with_doc"; then
++ AC_PATH_PROG(XSLTPROC,xsltproc)
++ if test -n "$XSLTPROC"; then
++ DOC_TARGET=doc
++ fi
+ fi
+ AC_SUBST(DOC_TARGET)
+
diff --git a/sys-libs/talloc/talloc-2.0.0-r1.ebuild b/sys-libs/talloc/talloc-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..b362403963fc
--- /dev/null
+++ b/sys-libs/talloc/talloc-2.0.0-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/talloc/talloc-2.0.0-r1.ebuild,v 1.1 2009/10/23 16:27:11 patrick Exp $
+
+EAPI="2"
+
+inherit confutils eutils autotools
+
+DESCRIPTION="Samba talloc library"
+HOMEPAGE="http://talloc.samba.org/"
+SRC_URI="http://samba.org/ftp/talloc/${P}.tar.gz"
+LICENSE="GPL-3"
+IUSE="compat doc"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc64 ~x86"
+
+DEPEND="
+ doc? ( app-text/docbook-xml-dtd:4.2 )
+ !net-fs/samba-libs[talloc]
+ !<net-fs/samba-libs-3.4
+ "
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+
+ epatch "${FILESDIR}"/${P}-without-doc.patch
+ eautoconf -Ilibreplace
+ sed -e 's:$(SHLD_FLAGS) :$(SHLD_FLAGS) $(LDFLAGS) :' -i Makefile.in
+}
+
+src_configure() {
+
+ econf \
+ --sysconfdir=/etc/samba \
+ --localstatedir=/var \
+ $(use_enable compat talloc-compat1) \
+ $(use_with doc) \
+ || die "econf failed"
+
+}
+
+src_compile() {
+
+ emake showflags || die "emake showflags failed"
+ emake shared-build || die "emake shared-build failed"
+
+}
+
+src_install() {
+
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dolib.a sharedbuild/lib/libtalloc.a
+ dolib.so sharedbuild/lib/libtalloc.so
+
+}