summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/drupal/drupal-5.8.ebuild')
-rw-r--r--www-apps/drupal/drupal-5.8.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/www-apps/drupal/drupal-5.8.ebuild b/www-apps/drupal/drupal-5.8.ebuild
index 06e7bce67a8e..7a1df108fcce 100644
--- a/www-apps/drupal/drupal-5.8.ebuild
+++ b/www-apps/drupal/drupal-5.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-apps/drupal/drupal-5.8.ebuild,v 1.1 2008/07/14 11:33:12 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-apps/drupal/drupal-5.8.ebuild,v 1.2 2008/07/15 10:50:21 pva Exp $
inherit webapp eutils depend.php
@@ -21,9 +21,13 @@ pkg_setup() {
webapp_pkg_setup
has_php
if [[ ${PHP_VERSION} == "4" ]] ; then
- require_php_with_use expat gd
+ local flags="expat"
else
- require_php_with_use xml gd
+ local flags="xml"
+ fi
+ if ! PHPCHECKNODIE="yes" require_php_with_use ${flags} \
+ || ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external ; then
+ die "Re-install ${PHP_PKG} with ${flags} and either gd or gd-external"
fi
}