summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/firefox/firefox-9.0.ebuild')
-rw-r--r--www-client/firefox/firefox-9.0.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/www-client/firefox/firefox-9.0.ebuild b/www-client/firefox/firefox-9.0.ebuild
index e3b1417fe38a..595b512a00b2 100644
--- a/www-client/firefox/firefox-9.0.ebuild
+++ b/www-client/firefox/firefox-9.0.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-client/firefox/firefox-9.0.ebuild,v 1.1 2011/12/21 16:11:05 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-client/firefox/firefox-9.0.ebuild,v 1.2 2011/12/22 08:36:53 polynomial-c Exp $
EAPI="3"
VIRTUALX_REQUIRED="pgo"
WANT_AUTOCONF="2.1"
-inherit flag-o-matic toolchain-funcs eutils gnome2-utils mozconfig-3 multilib pax-utils fdo-mime autotools mozextension versionator python virtualx nsplugins
+inherit check-reqs flag-o-matic toolchain-funcs eutils gnome2-utils mozconfig-3 multilib pax-utils fdo-mime autotools mozextension versionator python virtualx nsplugins
MAJ_FF_PV="$(get_version_component_range 1-2)" # 3.5, 3.6, 4.0, etc.
FF_PV="${PV/_alpha/a}" # Handle alpha for SRC_URI
@@ -149,13 +149,12 @@ pkg_setup() {
fi
# Ensure we have enough disk space to compile
- if use pgo ; then
+ if use pgo || use debug || use test ; then
CHECKREQS_DISK_BUILD="8G"
- check-reqs_pkg_setup
else
CHECKREQS_DISK_BUILD="4G"
- check-reqs_pkg_setup
fi
+ check-reqs_pkg_setup
}
src_unpack() {