summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/ochusha/ochusha-0.5.8.2.ebuild')
-rw-r--r--www-client/ochusha/ochusha-0.5.8.2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/www-client/ochusha/ochusha-0.5.8.2.ebuild b/www-client/ochusha/ochusha-0.5.8.2.ebuild
new file mode 100644
index 000000000000..47a4c7c28c83
--- /dev/null
+++ b/www-client/ochusha/ochusha-0.5.8.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/ochusha/ochusha-0.5.8.2.ebuild,v 1.1 2005/09/29 09:12:10 usata Exp $
+
+inherit flag-o-matic
+
+IUSE="nls ssl"
+
+DESCRIPTION="Ochusha - 2ch viewer for GTK+"
+HOMEPAGE="http://ochusha.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/${PN}/16560/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~ppc ~ppc64 ~x86"
+
+DEPEND="virtual/xft
+ >=x11-libs/gtk+-2.2.4
+ >=dev-libs/glib-2.2.3
+ >=dev-libs/libxml2-2.5.0
+ >=gnome-base/libghttp-1.0.9
+ sys-libs/zlib
+ nls? ( sys-devel/gettext )
+ ssl? ( dev-libs/openssl )"
+
+src_compile() {
+
+ econf $(use_enable nls) \
+ $(use_with ssl) \
+ --enable-regex \
+ --disable-shared \
+ --enable-static \
+ --with-included-oniguruma || die
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ dodoc ABOUT-NLS ACKNOWLEDGEMENT AUTHORS BUGS \
+ ChangeLog INSTALL* NEWS README TODO
+}