summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-plugins/gecko-mediaplayer/gecko-mediaplayer-1.0.4.ebuild')
-rw-r--r--www-plugins/gecko-mediaplayer/gecko-mediaplayer-1.0.4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/www-plugins/gecko-mediaplayer/gecko-mediaplayer-1.0.4.ebuild b/www-plugins/gecko-mediaplayer/gecko-mediaplayer-1.0.4.ebuild
new file mode 100644
index 000000000000..36bb318217e1
--- /dev/null
+++ b/www-plugins/gecko-mediaplayer/gecko-mediaplayer-1.0.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/gecko-mediaplayer/gecko-mediaplayer-1.0.4.ebuild,v 1.1 2011/07/04 14:15:54 ssuominen Exp $
+
+EAPI=4
+inherit multilib nsplugins
+
+DESCRIPTION="A browser plugin that uses GNOME MPlayer"
+HOMEPAGE="http://code.google.com/p/gecko-mediaplayer/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="curl"
+
+RDEPEND=">=dev-libs/dbus-glib-0.92
+ >=dev-libs/glib-2.26:2
+ dev-libs/nspr
+ >=media-video/gnome-mplayer-1.0.4[dbus]
+ >=net-libs/xulrunner-1.9.2:1.9
+ curl? ( net-misc/curl )
+ !www-client/chromium"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+DOCS="ChangeLog DOCS/tech/javascript.txt"
+
+src_configure() {
+ econf \
+ --without-gconf \
+ --with-gio \
+ --with-plugin-dir=/usr/$(get_libdir)/${PLUGINS_DIR} \
+ $(use_with curl libcurl)
+}
+
+src_install() {
+ default
+ rm -rf "${ED}"/usr/share/doc/${PN}
+}