summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-plugins/google-talkplugin/google-talkplugin-2.2.2.0.ebuild')
-rw-r--r--www-plugins/google-talkplugin/google-talkplugin-2.2.2.0.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/www-plugins/google-talkplugin/google-talkplugin-2.2.2.0.ebuild b/www-plugins/google-talkplugin/google-talkplugin-2.2.2.0.ebuild
index 24808ee1ee9e..91608e855dd9 100644
--- a/www-plugins/google-talkplugin/google-talkplugin-2.2.2.0.ebuild
+++ b/www-plugins/google-talkplugin/google-talkplugin-2.2.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-plugins/google-talkplugin/google-talkplugin-2.2.2.0.ebuild,v 1.1 2011/08/16 21:10:51 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-plugins/google-talkplugin/google-talkplugin-2.2.2.0.ebuild,v 1.2 2011/09/14 17:28:09 ottxor Exp $
EAPI=4
@@ -27,7 +27,7 @@ SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
#GoogleTalkPlugin binary contains openssl
LICENSE="google-talkplugin openssl"
-RESTRICT="strip mirror"
+RESTRICT="fetch strip"
#to get these run:
#for i in $(scanelf -n /opt/google/talkplugin/* | awk '/^ET/{gsub(/,/,"\n",$2);print $2}' | sort -u)
@@ -77,11 +77,13 @@ QA_DT_HASH="${INSTALL_BASE}/libnpg.*so
S="${WORKDIR}"
-# nofetch means upstream bumped and thus needs version bump
pkg_nofetch() {
- einfo "This version is no longer available from Google."
- einfo "Note that Gentoo cannot mirror the distfiles due to license reasons, so we have to follow the bump."
- einfo "Please file a version bump bug on http://bugs.gentoo.org (search existing bugs for ${PN} first!)."
+ elog "This version is no longer available from Google and the license prevents mirroring."
+ elog "This ebuild is intended for users who already downloaded it previously and have problems"
+ elog "with ${PV}+. If you can get the distfile from e.g. another computer of yours, or search"
+ use amd64 && MY_PKG="${MY_PKG/i386/amd64}"
+ elog "it with google: http://www.google.com/search?q=intitle:%22index+of%22+${MY_PKG}"
+ elog "and copy the file ${MY_PKG} to ${DISTDIR}."
}
src_unpack() {