summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtk+/ChangeLog7
-rw-r--r--x11-libs/gtk+/Manifest2
-rw-r--r--x11-libs/gtk+/files/digest-gtk+-2.8.92
-rw-r--r--x11-libs/gtk+/gtk+-2.8.9.ebuild142
4 files changed, 152 insertions, 1 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index 44fa418955cc..22fd39ef843c 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/gtk+
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.203 2005/12/13 20:41:18 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.204 2005/12/13 22:03:42 dang Exp $
+
+*gtk+-2.8.9 (13 Dec 2005)
+
+ 13 Dec 2005; <dang@gentoo.org> +gtk+-2.8.9.ebuild:
+ New upstream version
13 Dec 2005; Seemant Kulleen <seemant@gentoo.org> gtk+-1.2.10-r11.ebuild:
modular X deps, committing Donnie's fixes in bug #115232
diff --git a/x11-libs/gtk+/Manifest b/x11-libs/gtk+/Manifest
index c533cf308f2b..2d06ba6d16c8 100644
--- a/x11-libs/gtk+/Manifest
+++ b/x11-libs/gtk+/Manifest
@@ -6,6 +6,7 @@ MD5 71f1edf217fe1b660ed78cd89f9832b2 files/digest-gtk+-2.6.8 208
MD5 e9729297feed3e63e6176140ee4cb463 files/digest-gtk+-2.8.6-r1 140
MD5 b86433093efb1cf276e40b89c7bcb832 files/digest-gtk+-2.8.7 140
MD5 c2395b72772f29144c0b34c311e68b26 files/digest-gtk+-2.8.8 140
+MD5 08ac67047e9ffc29d4e51f7df2d7dc88 files/digest-gtk+-2.8.9 140
MD5 5e3ff7fa761495300d3f30c9207c13f8 files/gtk+-1.2-locale_fix.patch 419
MD5 0ec83a4bf20f79d85eb2976b58c39465 files/gtk+-1.2.10-m4.patch 220
MD5 cd1c96c0a81026a3af29449389e455d5 files/gtk+-2-xpm_loader.patch 920
@@ -21,4 +22,5 @@ MD5 5033b22f68c770cc1738680edc951abf gtk+-2.6.8.ebuild 2884
MD5 24536341521e59874250c967c2c984bd gtk+-2.8.6-r1.ebuild 4222
MD5 4c3121a26f06dd7b0d5ef089f03ea1e9 gtk+-2.8.7.ebuild 4009
MD5 c750967f729be73db0640badfae3819b gtk+-2.8.8.ebuild 3835
+MD5 c750967f729be73db0640badfae3819b gtk+-2.8.9.ebuild 3835
MD5 58b5c1a403ab43f5160c44c32761cbe0 metadata.xml 424
diff --git a/x11-libs/gtk+/files/digest-gtk+-2.8.9 b/x11-libs/gtk+/files/digest-gtk+-2.8.9
new file mode 100644
index 000000000000..223aacd221df
--- /dev/null
+++ b/x11-libs/gtk+/files/digest-gtk+-2.8.9
@@ -0,0 +1,2 @@
+MD5 0c7c66269cbac694971341dd2b2adf3d gtk+-2-smoothscroll-r6.patch.bz2 3718
+MD5 e7a94132ae6353106c80cd4a1106a368 gtk+-2.8.9.tar.bz2 11949090
diff --git a/x11-libs/gtk+/gtk+-2.8.9.ebuild b/x11-libs/gtk+/gtk+-2.8.9.ebuild
new file mode 100644
index 000000000000..ab4189552429
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-2.8.9.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.8.9.ebuild,v 1.1 2005/12/13 22:03:43 dang Exp $
+
+inherit gnome.org flag-o-matic eutils debug
+
+DESCRIPTION="Gimp ToolKit +"
+HOMEPAGE="http://www.gtk.org/"
+SRC_URI="${SRC_URI}
+ mirror://gentoo/gtk+-2-smoothscroll-r6.patch.bz2"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug doc jpeg tiff"
+
+RDEPEND="|| ( (
+ x11-libs/libXrender
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXt
+ x11-libs/libXext
+ x11-libs/libXinerama
+ x11-libs/libXcursor
+ x11-libs/libXrandr
+ x11-libs/libXfixes )
+ virtual/x11 )
+
+ >=dev-libs/glib-2.7.1
+ >=x11-libs/pango-1.9
+ >=dev-libs/atk-1.0.1
+ >=x11-libs/cairo-0.9.2
+ x11-misc/shared-mime-info
+ >=media-libs/libpng-1.2.1
+ media-libs/fontconfig
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ tiff? ( >=media-libs/tiff-3.5.7 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ sys-devel/autoconf
+ >=sys-devel/automake-1.7.9
+
+ || ( (
+ x11-proto/xextproto
+ x11-proto/xproto
+ x11-proto/inputproto
+ x11-proto/xineramaproto )
+ virtual/x11 )
+
+ doc? (
+ >=dev-util/gtk-doc-1.4
+ ~app-text/docbook-xml-dtd-4.1.2 )"
+
+
+pkg_setup() {
+ if ! built_with_use x11-libs/cairo X; then
+ einfo "Please re-emerge x11-libs/cairo with the X USE flag set"
+ die "cairo needs the X flag set"
+ fi
+}
+
+set_gtk2_confdir() {
+ # An arch specific config directory is used on multilib systems
+ has_multilib_profile && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
+ use x86 && [ "$(get_libdir)" == "lib32" ] && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
+ GTK2_CONFDIR=${GTK2_CONFDIR:=/etc/gtk-2.0}
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # beautifying patch for disabled icons
+ epatch "${FILESDIR}"/${PN}-2.2.1-disable_icons_smooth_alpha.patch
+ # add smoothscroll support for usability reasons
+ # http://bugzilla.gnome.org/show_bug.cgi?id=103811
+ epatch "${DISTDIR}"/${PN}-2-smoothscroll-r6.patch.bz2
+
+ # use an arch-specific config directory so that 32bit and 64bit versions
+ # dont clash on multilib systems
+ has_multilib_profile && epatch "${FILESDIR}"/${PN}-2.8.0-multilib.patch
+
+ # and this line is just here to make building emul-linux-x86-gtklibs a bit
+ # easier, so even this should be amd64 specific.
+ if use x86 && [ "$(get_libdir)" == "lib32" ]; then
+ epatch "${FILESDIR}"/${PN}-2.8.0-multilib.patch
+ fi
+
+ use ppc64 && append-flags -mminimal-toc
+
+ autoconf || die "autoconf failed"
+ automake || die "automake failed"
+
+ epunt_cxx
+}
+
+src_compile() {
+ local myconf="$(use_enable doc gtk-doc) \
+ $(use_with jpeg libjpeg) \
+ $(use_with tiff libtiff) \
+ --with-libpng \
+ --with-gdktarget=x11 \
+ --with-xinput"
+
+ # Passing --disable-debug is not recommended for production use
+ use debug && myconf="${myconf} --enable-debug=yes"
+
+ econf $myconf || die "./configure failed to run"
+
+ emake || die "gtk+ failed to compile"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ set_gtk2_confdir
+ dodir ${GTK2_CONFDIR}
+ keepdir ${GTK2_CONFDIR}
+
+ # Enable xft in environment as suggested by <utx@gentoo.org>
+ dodir /etc/env.d
+ echo "GDK_USE_XFT=1" > ${D}/etc/env.d/50gtk2
+
+ dodoc AUTHORS ChangeLog* HACKING NEWS* README*
+}
+
+pkg_postinst() {
+ set_gtk2_confdir
+
+ if [ -d "${ROOT}${GTK2_CONFDIR}" ]; then
+ gtk-query-immodules-2.0 > ${ROOT}${GTK2_CONFDIR}/gtk.immodules
+ gdk-pixbuf-query-loaders > ${ROOT}${GTK2_CONFDIR}/gdk-pixbuf.loaders
+ else
+ ewarn "The destination path ${ROOT}${GTK2_CONFDIR} doesn't exist;"
+ ewarn "to complete the installation of GTK+, please create the"
+ ewarn "directory and then manually run:"
+ ewarn " cd ${ROOT}${GTK2_CONFDIR}"
+ ewarn " gtk-query-immodules-2.0 > gtk.immodules"
+ ewarn " gdk-pixbuf-query-loaders > gdk-pixbuf.loaders"
+ fi
+}