summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xmbdfed/files/xmbdfed-4.7_p1-gentoo.patch')
-rw-r--r--x11-misc/xmbdfed/files/xmbdfed-4.7_p1-gentoo.patch64
1 files changed, 64 insertions, 0 deletions
diff --git a/x11-misc/xmbdfed/files/xmbdfed-4.7_p1-gentoo.patch b/x11-misc/xmbdfed/files/xmbdfed-4.7_p1-gentoo.patch
new file mode 100644
index 000000000000..c338b1b27032
--- /dev/null
+++ b/x11-misc/xmbdfed/files/xmbdfed-4.7_p1-gentoo.patch
@@ -0,0 +1,64 @@
+diff -Naur xmbdfed-4.7.orig/Makefile xmbdfed-4.7/Makefile
+--- xmbdfed-4.7.orig/Makefile 2004-02-18 00:24:06.000000000 +0900
++++ xmbdfed-4.7/Makefile 2009-01-01 09:38:56.000000000 +0900
+@@ -23,7 +23,7 @@
+ # $Id: xmbdfed-4.7_p1-gentoo.patch,v 1.1 2009/01/01 01:33:50 matsuu Exp $
+ #
+ CC = gcc
+-CFLAGS = -g -Wall
++CFLAGS += -g -Wall
+
+ OTHER = README CHANGES COPYRIGHTS Makefile Imakefile.lesstif Project.tmpl \
+ xmbdfedrc xmbdfed.man
+@@ -46,9 +46,9 @@
+ # Uncomment these if you have the FreeType library and want to use it to
+ # import OpenType fonts.
+ #
+-#FTYPE_INCS = -I/usr/local/include
+-#FTYPE_LIBS = -L/usr/local/lib -lfreetype
+-#FTYPE_DEFS = -DHAVE_FREETYPE
++FTYPE_INCS = `freetype-config --cflags`
++FTYPE_LIBS = `freetype-config --libs`
++FTYPE_DEFS = -DHAVE_FREETYPE
+
+ #
+ # Uncomment these if you have the hbf.h and hbf.c files in the current
+@@ -64,7 +64,7 @@
+ # files with a ".gz" extension. If you don't care about HBF fonts, just
+ # comment this line out.
+ #
+-HBFDEFS = -Dunix -DIN_MEMORY -DGUNZIP_CMD="\"/usr/local/bin/gunzip -c\""
++HBFDEFS = -Dunix -DIN_MEMORY -DGUNZIP_CMD="\"/bin/gunzip -c\""
+
+ #
+ # Set the defines used for all files except the HBF support.
+@@ -82,15 +82,15 @@
+ #
+ # Uncomment these for Solaris.
+ #
+-INCS = -I/usr/openwin/include -I/usr/dt/include $(FTYPE_INCS)
+-LIBS = -R/usr/openwin/lib -R/usr/dt/lib -L/usr/dt/lib -lXm \
+- -L/usr/openwin/lib -lXmu -lXt -lXext -lX11 $(FTYPE_LIBS)
++#INCS = -I/usr/openwin/include -I/usr/dt/include $(FTYPE_INCS)
++#LIBS = -R/usr/openwin/lib -R/usr/dt/lib -L/usr/dt/lib -lXm \
++# -L/usr/openwin/lib -lXmu -lXt -lXext -lX11 $(FTYPE_LIBS)
+
+ #
+ # Uncomment these for Linux.
+ #
+-#INCS = -I/usr/X11/include $(FTYPE_INCS)
+-#LIBS = -L/usr/X11/lib -lXm -lXpm -lXmu -lXt -lXext -lX11 -lSM -lICE $(FTYPE_LIBS)
++INCS = -I/usr/include $(FTYPE_INCS)
++LIBS = -L/usr/lib -lXm -lXpm -lXmu -lXt -lXext -lX11 -lSM -lICE $(FTYPE_LIBS)
+
+ #
+ # Uncomment these for HPUX.
+@@ -132,7 +132,7 @@
+ all: xmbdfed
+
+ xmbdfed: $(OBJS)
+- $(PURIFY) $(CC) $(STATIC) $(CFLAGS) -o xmbdfed $(OBJS) $(LIBS)
++ $(PURIFY) $(CC) $(STATIC) $(CFLAGS) $(LDFLAGS) -o xmbdfed $(OBJS) $(LIBS)
+
+ hbf.o: hbf.c
+ $(CC) $(CFLAGS) $(DEFS) $(HBFDEFS) $(INCS) -c $< -o $@