summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xsnap/xsnap-1.5.6.ebuild')
-rw-r--r--x11-misc/xsnap/xsnap-1.5.6.ebuild29
1 files changed, 14 insertions, 15 deletions
diff --git a/x11-misc/xsnap/xsnap-1.5.6.ebuild b/x11-misc/xsnap/xsnap-1.5.6.ebuild
index a569c01f2564..1f7a0b4ee582 100644
--- a/x11-misc/xsnap/xsnap-1.5.6.ebuild
+++ b/x11-misc/xsnap/xsnap-1.5.6.ebuild
@@ -1,50 +1,49 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xsnap/xsnap-1.5.6.ebuild,v 1.1 2010/02/08 12:21:04 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xsnap/xsnap-1.5.6.ebuild,v 1.2 2010/06/06 16:05:52 ssuominen Exp $
+EAPI=2
inherit eutils toolchain-funcs
DESCRIPTION="Program to interactively take a 'snapshot' of a region of the screen"
-SRC_URI="ftp://ftp.ac-grenoble.fr/ge/Xutils/${P}.tar.bz2"
HOMEPAGE="ftp://ftp.ac-grenoble.fr/ge/Xutils/"
+SRC_URI="ftp://ftp.ac-grenoble.fr/ge/Xutils/${P}.tar.bz2"
-SLOT="0"
LICENSE="as-is"
+SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE=""
-RDEPEND="x11-libs/libX11
+COMMON_DEPEND="x11-libs/libX11
x11-libs/libXext
x11-libs/libXpm
media-libs/libpng
media-libs/jpeg"
-DEPEND="${RDEPEND}
+RDEPEND="${COMMON_DEPEND}
+ media-fonts/font-misc-misc"
+DEPEND="${COMMON_DEPEND}
x11-proto/xproto
app-text/rman
x11-misc/imake"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
epatch "${FILESDIR}"/${P}-gentoo.patch
- xmkmf || die "xmkmf failed"
- sed -i Makefile \
+ xmkmf || die
+ sed -i \
-e '/ CC = /d' \
-e '/ LD = /d' \
-e '/ CDEBUGFLAGS = /d' \
-e '/ CCOPTIONS = /d' \
-e 's|CPP = cpp|CPP = $(CC)|g' \
- || die "sed failed"
+ Makefile || die
}
src_compile() {
tc-export CC
- emake CCOPTIONS="${CFLAGS}" EXTRA_LDOPTIONS="${LDFLAGS}" || die "make failed"
+ emake CCOPTIONS="${CFLAGS}" EXTRA_LDOPTIONS="${LDFLAGS}" || die
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- make DESTDIR="${D}" install.man || die "make install.man failed"
+ emake DESTDIR="${D}" install install.man || die
dodoc README AUTHORS
}