summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xsri/xsri-2.1.0-r3.ebuild')
-rw-r--r--x11-misc/xsri/xsri-2.1.0-r3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-misc/xsri/xsri-2.1.0-r3.ebuild b/x11-misc/xsri/xsri-2.1.0-r3.ebuild
new file mode 100644
index 000000000000..3207bed7cd3a
--- /dev/null
+++ b/x11-misc/xsri/xsri-2.1.0-r3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xsri/xsri-2.1.0-r3.ebuild,v 1.1 2014/04/17 10:07:32 jer Exp $
+
+EAPI=5
+inherit autotools eutils rpm
+
+DESCRIPTION="The xsri wallpaper setter from RedHat"
+HOMEPAGE="http://fedoraproject.org"
+SRC_URI="http://download.fedoraproject.org/pub/fedora/linux/releases/15/Everything/source/SRPMS/${P}-17.fc12.src.rpm"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-configure.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS README
+ doman ../${PN}.1
+}