summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/desklet-weather/desklet-weather-0.21.ebuild')
-rw-r--r--x11-plugins/desklet-weather/desklet-weather-0.21.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-plugins/desklet-weather/desklet-weather-0.21.ebuild b/x11-plugins/desklet-weather/desklet-weather-0.21.ebuild
new file mode 100644
index 000000000000..f311c3b29dc5
--- /dev/null
+++ b/x11-plugins/desklet-weather/desklet-weather-0.21.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/desklet-weather/desklet-weather-0.21.ebuild,v 1.1 2003/09/09 05:23:46 obz Exp $
+
+DESKLET_NAME="Weather"
+
+MY_PN=${PN/desklet-/}-desklet
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A weather monitoring Sensor and Display for gdesklets"
+SRC_URI="http://gdesklets.gnomedesktop.org/files/${MY_P}.tar.bz2"
+HOMEPAGE="http://www.pycage.de/"
+LICENSE="as-is"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86"
+
+DEPEND=">=gnome-extra/gdesklets-core-0.20"
+
+DOCS="INSTALL README"
+
+src_install( ) {
+
+ SYS_PATH="/usr/share/gdesklets"
+ INSTALL_BIN="Install_${DESKLET_NAME}_Sensor.bin"
+ dodir ${SYS_PATH}/{Sensors,Displays}
+
+ # first we install the Sensor
+ python ${INSTALL_BIN} --nomsg ${D}${SYS_PATH}/Sensors
+
+ # and then the .displays
+ insinto ${SYS_PATH}/Displays/${DESKLET_NAME}
+ doins *.display
+
+ # and finally the graphics
+ cp -R gfx/ ${D}${SYS_PATH}/Displays/${DESKLET_NAME}
+
+ dodoc ${DOCS}
+
+}
+