summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/gkrellm-cpufreq/gkrellm-cpufreq-0.6.1.ebuild')
-rw-r--r--x11-plugins/gkrellm-cpufreq/gkrellm-cpufreq-0.6.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-plugins/gkrellm-cpufreq/gkrellm-cpufreq-0.6.1.ebuild b/x11-plugins/gkrellm-cpufreq/gkrellm-cpufreq-0.6.1.ebuild
new file mode 100644
index 000000000000..57a635ec3aa0
--- /dev/null
+++ b/x11-plugins/gkrellm-cpufreq/gkrellm-cpufreq-0.6.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellm-cpufreq/gkrellm-cpufreq-0.6.1.ebuild,v 1.1 2007/07/15 17:58:10 lack Exp $
+
+inherit gkrellm-plugin
+
+MY_P=${P/gkrellm/gkrellm2}
+
+DESCRIPTION="A Gkrellm2 plugin for displaying and manipulating CPU frequency"
+HOMEPAGE="http://iacs.epfl.ch/~winkelma/gkrellm2-cpufreq/"
+SRC_URI="http://iacs.epfl.ch/~winkelma/gkrellm2-cpufreq//${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+RDEPEND="sys-power/cpufrequtils
+ app-admin/sudo"
+
+PLUGIN_SO=cpufreq.so
+
+src_install() {
+ gkrellm-plugin_src_install
+ exeinto /usr/sbin
+ doexe cpufreqnextgovernor
+}
+
+pkg_postinst() {
+ echo
+ einfo "Add these lines to /etc/sudoers to allow users to change cpu governor and speed:"
+ einfo "ALL ALL = (root) NOPASSWD: /usr/bin/cpufreq-set -c [0-9]* -g userspace"
+ einfo "ALL ALL = (root) NOPASSWD: /usr/bin/cpufreq-set -c [0-9]* -f [0-9]*"
+ einfo "ALL ALL = (root) NOPASSWD: /usr/sbin/cpufreqnextgovernor"
+ echo
+}
+