summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmwave/wmwave-0.4.ebuild')
-rw-r--r--x11-plugins/wmwave/wmwave-0.4.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/x11-plugins/wmwave/wmwave-0.4.ebuild b/x11-plugins/wmwave/wmwave-0.4.ebuild
index 8f6ef501b697..03f37610354d 100644
--- a/x11-plugins/wmwave/wmwave-0.4.ebuild
+++ b/x11-plugins/wmwave/wmwave-0.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmwave/wmwave-0.4.ebuild,v 1.7 2005/11/11 11:36:29 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmwave/wmwave-0.4.ebuild,v 1.8 2006/01/31 21:06:41 nelchael Exp $
IUSE=""
S="${WORKDIR}/wmwave"
@@ -9,9 +9,16 @@ DESCRIPTION="wmwave is a dockapp that displays quality, link, level and noise of
SRC_URI="mirror://sourceforge/wmwave/${PN}-0-4.tgz"
HOMEPAGE="http://wmwave.sourceforge.net/"
LICENSE="GPL-2"
-DEPEND="virtual/x11"
SLOT="0"
+RDEPEND="|| ( (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm )
+ virtual/x11 )"
+DEPEND="${RDEPEND}
+ || ( x11-proto/xextproto virtual/x11 )"
+
src_compile() {
emake FLAGS="${CFLAGS}" || die "Compilation failed"
}