summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmauda/ChangeLog8
-rw-r--r--x11-plugins/wmauda/files/wmauda-0.9-asneeded.patch22
-rw-r--r--x11-plugins/wmauda/wmauda-0.9.ebuild37
3 files changed, 66 insertions, 1 deletions
diff --git a/x11-plugins/wmauda/ChangeLog b/x11-plugins/wmauda/ChangeLog
index 80e3fbd249f5..96feeab282f5 100644
--- a/x11-plugins/wmauda/ChangeLog
+++ b/x11-plugins/wmauda/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/wmauda
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmauda/ChangeLog,v 1.18 2012/05/05 05:12:00 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmauda/ChangeLog,v 1.19 2012/10/02 15:25:07 voyageur Exp $
+
+*wmauda-0.9 (02 Oct 2012)
+
+ 02 Oct 2012; Bernard Cafarelli <voyageur@gentoo.org> +wmauda-0.9.ebuild,
+ +files/wmauda-0.9-asneeded.patch:
+ Version bump
05 May 2012; Jeff Horelick <jdhore@gentoo.org> wmauda-0.7.ebuild,
wmauda-0.8.ebuild:
diff --git a/x11-plugins/wmauda/files/wmauda-0.9-asneeded.patch b/x11-plugins/wmauda/files/wmauda-0.9-asneeded.patch
new file mode 100644
index 000000000000..0277cb742d9d
--- /dev/null
+++ b/x11-plugins/wmauda/files/wmauda-0.9-asneeded.patch
@@ -0,0 +1,22 @@
+--- Makefile.orig 2012-03-27 00:27:20.000000000 +0200
++++ Makefile 2012-10-02 17:19:54.924905300 +0200
+@@ -7,8 +7,8 @@
+ PIXMAP_DIR := $(PREFIX)/share/pixmaps
+ MANPAGE_DIR := $(PREFIX)/share/man/man1
+
+-CFLAGS += $(shell pkg-config audacious --cflags) $(shell pkg-config dbus-1 --cflags) -DPIXMAP_DIR="\"$(PIXMAP_DIR)\""
+-LIBS := $(shell pkg-config audacious --libs) $(shell pkg-config audclient --libs) $(shell pkg-config dbus-1 --libs)
++CFLAGS += $(shell pkg-config audclient --cflags) $(shell pkg-config dbus-glib-1 --cflags) -DPIXMAP_DIR="\"$(PIXMAP_DIR)\""
++LIBS := $(shell pkg-config audclient --libs) $(shell pkg-config dbus-glib-1 --libs) -lX11
+
+ CFLAGS += $(shell pkg-config gtk+-2.0 --cflags)
+ LIBS += $(shell pkg-config gtk+-2.0 --libs)
+@@ -17,7 +17,7 @@
+ HEADERS = dock-master.xpm
+
+ wmauda: $(OBJS) $(HEADERS)
+- $(CC) -o wmauda $(OBJS) $(CFLAGS) $(LIBS)
++ $(CC) $(LDFLAGS) -o wmauda $(OBJS) $(CFLAGS) $(LIBS)
+
+ all: wmauda
+
diff --git a/x11-plugins/wmauda/wmauda-0.9.ebuild b/x11-plugins/wmauda/wmauda-0.9.ebuild
new file mode 100644
index 000000000000..9f9dd098ddec
--- /dev/null
+++ b/x11-plugins/wmauda/wmauda-0.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmauda/wmauda-0.9.ebuild,v 1.1 2012/10/02 15:25:07 voyageur Exp $
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Dockable applet for WindowMaker that controls Audacious."
+HOMEPAGE="http://www.netswarm.net"
+SRC_URI="http://www.netswarm.net/misc/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/dbus-glib
+ x11-libs/libX11
+ x11-libs/gtk+:2
+ >=media-sound/audacious-1.5"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake PREFIX="/usr"
+}
+
+src_install () {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+ dodoc AUTHORS README
+}