summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/blueglass-xcursors/blueglass-xcursors-0.3-r1.ebuild')
-rw-r--r--x11-themes/blueglass-xcursors/blueglass-xcursors-0.3-r1.ebuild18
1 files changed, 12 insertions, 6 deletions
diff --git a/x11-themes/blueglass-xcursors/blueglass-xcursors-0.3-r1.ebuild b/x11-themes/blueglass-xcursors/blueglass-xcursors-0.3-r1.ebuild
index 5b1d7db0bd2f..239b9a61daef 100644
--- a/x11-themes/blueglass-xcursors/blueglass-xcursors-0.3-r1.ebuild
+++ b/x11-themes/blueglass-xcursors/blueglass-xcursors-0.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/blueglass-xcursors/blueglass-xcursors-0.3-r1.ebuild,v 1.4 2004/06/25 03:02:55 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/blueglass-xcursors/blueglass-xcursors-0.3-r1.ebuild,v 1.5 2004/10/04 01:36:22 spyderous Exp $
MY_P="5532-BlueGlass-XCursors-3D-${PV}"
DESCRIPTION="A high quality set of Xfree 4.3.0 animated mouse cursors"
@@ -11,14 +11,20 @@ SLOT="0"
KEYWORDS="x86"
IUSE=""
DEPEND=""
-RDEPEND=">=x11-base/xfree-4.3.0-r2"
+RDEPEND="virtual/x11"
# Note: although the package name is BlueGlass, the tarball & authors directions
# use the directory 'Blue'.
src_install() {
- mkdir -p ${D}/usr/share/cursors/xfree/Blue/cursors/
- cp -d ${WORKDIR}/${MY_P:5}/Blue/cursors/* ${D}/usr/share/cursors/xfree/Blue/cursors/ || die
- dodoc ${WORKDIR}/${MY_P:5}/{COPYING,README}
+ # Set up X11 implementation
+ X11_IMPLEM_P="$(best_version virtual/x11)"
+ X11_IMPLEM="${X11_IMPLEM_P%-[0-9]*}"
+ X11_IMPLEM="${X11_IMPLEM##*\/}"
+ einfo "X11 implementation is ${X11_IMPLEM}."
+
+ dodir /usr/share/cursors/${X11_IMPLEM}/Blue/cursors/
+ cp -d ${WORKDIR}/${MY_P:5}/Blue/cursors/* ${D}/usr/share/cursors/${X11_IMPLEM}/Blue/cursors/ || die
+ dodoc ${WORKDIR}/${MY_P:5}/README
}
pkg_postinst() {
@@ -30,7 +36,7 @@ pkg_postinst() {
einfo "Xcursor.size: 48"
einfo ""
einfo "To globally use this set of mouse cursors edit the file:"
- einfo " /usr/share/cursors/xfree/default/index.theme"
+ einfo " /usr/share/cursors/${X11_IMPLEM}/default/index.theme"
einfo "and change the line:"
einfo " Inherits=[current setting]"
einfo "to"