summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/ion')
-rw-r--r--x11-wm/ion/ChangeLog7
-rw-r--r--x11-wm/ion/Manifest8
-rw-r--r--x11-wm/ion/files/digest-ion-20020207-r21
-rw-r--r--x11-wm/ion/ion-20020207-r2.ebuild61
4 files changed, 72 insertions, 5 deletions
diff --git a/x11-wm/ion/ChangeLog b/x11-wm/ion/ChangeLog
index dd298580effb..9a3be03b18e4 100644
--- a/x11-wm/ion/ChangeLog
+++ b/x11-wm/ion/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-wm/ion
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion/ChangeLog,v 1.13 2005/07/10 15:19:56 twp Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion/ChangeLog,v 1.14 2006/01/25 16:43:32 twp Exp $
+
+ 25 Jan 2006; Tom Payne <twp@gentoo.org> ChangeLog:
+ Update for Modular X.
10 Jul 2005; Tom Payne <twp@gentoo.org> -ion-20020207.ebuild,
ion-20020207-r1.ebuild:
diff --git a/x11-wm/ion/Manifest b/x11-wm/ion/Manifest
index 700ed8ff295d..f7db55223fdc 100644
--- a/x11-wm/ion/Manifest
+++ b/x11-wm/ion/Manifest
@@ -1,5 +1,7 @@
-MD5 533e6fc50c28fbaf47adf485e88a2fbe ion-20020207-r1.ebuild 1426
-MD5 19f6197c6f16bf0449e676bda279d889 ChangeLog 1818
-MD5 f6555db271f0c723017c417e06c2acf1 metadata.xml 541
+MD5 8c5aa2e8398262cb5aafdbd6a5c9fc1f ChangeLog 1896
MD5 1859f463f0b88ba4a73c5051923c6095 files/digest-ion-20020207-r1 64
+MD5 1859f463f0b88ba4a73c5051923c6095 files/digest-ion-20020207-r2 64
MD5 6487fe95ece5d2b01629c2735b2b6e1a files/ion-20020207-gentoo.diff 391
+MD5 533e6fc50c28fbaf47adf485e88a2fbe ion-20020207-r1.ebuild 1426
+MD5 d5e9a5f899d443bb4a93acdcc75c8c93 ion-20020207-r2.ebuild 1519
+MD5 f6555db271f0c723017c417e06c2acf1 metadata.xml 541
diff --git a/x11-wm/ion/files/digest-ion-20020207-r2 b/x11-wm/ion/files/digest-ion-20020207-r2
new file mode 100644
index 000000000000..2c51c5253f43
--- /dev/null
+++ b/x11-wm/ion/files/digest-ion-20020207-r2
@@ -0,0 +1 @@
+MD5 2e909abb45efefb08b1ceb886bf34cfe ion-20020207.tar.gz 157649
diff --git a/x11-wm/ion/ion-20020207-r2.ebuild b/x11-wm/ion/ion-20020207-r2.ebuild
new file mode 100644
index 000000000000..fa51b75bf5de
--- /dev/null
+++ b/x11-wm/ion/ion-20020207-r2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ion/ion-20020207-r2.ebuild,v 1.1 2006/01/25 16:43:32 twp Exp $
+
+inherit eutils
+
+DESCRIPTION="A keyboard-based window manager"
+HOMEPAGE="http://www.students.tut.fi/~tuomov/ion/"
+SRC_URI="http://www.students.tut.fi/~tuomov/dl/${P}.tar.gz"
+
+LICENSE="Clarified-Artistic"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE=""
+
+RDEPEND="|| (
+ x11-libs/libX11
+ virtual/x11
+ )"
+DEPEND="${RDEPEND}
+ || (
+ x11-xproto/xproto
+ virtual/x11
+ )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.diff
+}
+
+src_compile() {
+ # Edit system.mk
+ cp system.mk system.mk.new
+ sed -e 's:PREFIX=/usr/local:PREFIX=/usr:' \
+ -e 's:ETCDIR=$(PREFIX)/etc:ETCDIR=/etc/X11:' \
+ -e 's:$(PREFIX)/man:$(PREFIX)/share/man:' \
+ -e 's:$(PREFIX)/doc:$(PREFIX)/share/doc:' \
+ -e 's:#HAS_SYSTEM_ASPRINTF=1:HAS_SYSTEM_ASPRINTF=1:' \
+ -e 's:#INSTALL=install -c:INSTALL=install -c:' \
+ -e 's:INSTALL=install *$:#INSTALL=install:' \
+ -e 's:-pedantic-errors ::g' \
+ system.mk.new > system.mk
+
+ cp Makefile Makefile.new
+ sed -e 's:$(DOCDIR)/ion:$(DOCDIR)/${P}:g' \
+ Makefile.new > Makefile
+
+ make depend || die
+ emake || die
+}
+
+src_install () {
+ make PREFIX=${D}/usr ETCDIR=${D}/etc/X11 install || die
+}
+
+pkg_postinst () {
+ einfo "Configuration documentation can be found in these places:"
+ einfo "/usr/share/doc/${P}/config.txt"
+ einfo "http://www.students.tut.fi/~tuomov/ion/resources.html"
+}