summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-base/xfce4-panel/xfce4-panel-4.7.1.ebuild')
-rw-r--r--xfce-base/xfce4-panel/xfce4-panel-4.7.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/xfce-base/xfce4-panel/xfce4-panel-4.7.1.ebuild b/xfce-base/xfce4-panel/xfce4-panel-4.7.1.ebuild
new file mode 100644
index 000000000000..105674169393
--- /dev/null
+++ b/xfce-base/xfce4-panel/xfce4-panel-4.7.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-panel/xfce4-panel-4.7.1.ebuild,v 1.1 2010/03/29 14:55:04 ssuominen Exp $
+
+EAPI=3
+inherit xfconf
+
+DESCRIPTION="Panel for Xfce4"
+HOMEPAGE="http://www.xfce.org/projects/xfce4-panel/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/4.7/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug"
+
+RDEPEND="x11-libs/libX11
+ >=xfce-base/libxfce4util-4.6
+ >=xfce-base/garcon-0.1.1
+ >=xfce-base/libxfce4ui-4.7.1
+ >=xfce-base/xfconf-4.7.2
+ >=xfce-base/exo-0.5.1
+ >=x11-libs/gtk+-2.14:2
+ >=dev-libs/glib-2.18:2
+ >=dev-libs/dbus-glib-0.73
+ >=x11-libs/cairo-1
+ >=x11-libs/libwnck-2.22"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ XFCONF="--docdir=${EPREFIX}/usr/share/doc/${PF}
+ --disable-dependency-tracking
+ --disable-static
+ $(xfconf_use_debug)
+ --with-html-dir=${EPREFIX}/usr/share/doc/${PF}/html"
+ DOCS="AUTHORS ChangeLog NEWS THANKS"
+}