summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-dict/xfce4-dict-0.4.1.ebuild')
-rw-r--r--xfce-extra/xfce4-dict/xfce4-dict-0.4.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-dict/xfce4-dict-0.4.1.ebuild b/xfce-extra/xfce4-dict/xfce4-dict-0.4.1.ebuild
new file mode 100644
index 000000000000..774722f249b8
--- /dev/null
+++ b/xfce-extra/xfce4-dict/xfce4-dict-0.4.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-dict/xfce4-dict-0.4.1.ebuild,v 1.1 2008/11/06 20:21:59 angelos Exp $
+
+EAPI=1
+
+inherit fdo-mime gnome2-utils
+
+DESCRIPTION="plugin and stand-alone application to query dict.org"
+HOMEPAGE="http://goodies.xfce.org/projects/applications/xfce4-dict"
+SRC_URI="http://goodies.xfce.org/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.6:2
+ >=x11-libs/gtk+-2.6:2
+ >=xfce-base/libxfcegui4-4.4
+ >=xfce-base/libxfce4util-4.4
+ >=xfce-base/xfce4-panel-4.4"
+DEPEND="${RDEPEND}
+ dev-util/intltool"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}