summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-indicator-plugin/ChangeLog10
-rw-r--r--xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.3.3.ebuild37
2 files changed, 45 insertions, 2 deletions
diff --git a/xfce-extra/xfce4-indicator-plugin/ChangeLog b/xfce-extra/xfce4-indicator-plugin/ChangeLog
index d923b7b0951c..aeb009a6e206 100644
--- a/xfce-extra/xfce4-indicator-plugin/ChangeLog
+++ b/xfce-extra/xfce4-indicator-plugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/xfce4-indicator-plugin
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-indicator-plugin/ChangeLog,v 1.21 2014/03/18 18:23:42 ssuominen Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-indicator-plugin/ChangeLog,v 1.22 2015/04/12 19:10:53 mgorny Exp $
+
+*xfce4-indicator-plugin-2.3.3 (12 Apr 2015)
+
+ 12 Apr 2015; Michał Górny <mgorny@gentoo.org>
+ +xfce4-indicator-plugin-2.3.3.ebuild:
+ Version bump with minor fixes.
18 Mar 2014; Samuli Suominen <ssuominen@gentoo.org>
-xfce4-indicator-plugin-2.3.1.ebuild:
diff --git a/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.3.3.ebuild b/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.3.3.ebuild
new file mode 100644
index 000000000000..35ba0ef64164
--- /dev/null
+++ b/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.3.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.3.3.ebuild,v 1.1 2015/04/12 19:10:53 mgorny Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="A panel plugin that uses indicator-applet to show new messages"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-indicator-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/libindicator-12.10.1:3=
+ >=x11-libs/gtk+-3.6:3=
+ x11-libs/libX11:=
+ >=xfce-base/libxfce4ui-4.11:=
+ >=xfce-base/libxfce4util-4.11:=
+ >=xfce-base/xfce4-panel-4.11:=
+ >=xfce-base/xfconf-4.10:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ # TODO: libido3-13.10.0 needs ubuntu-private.h from Ubuntu's GTK+ 3.x
+ XFCONF=(
+ --disable-ido
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README THANKS )
+}