summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/xen/xen-3.0.3.ebuild')
-rw-r--r--app-emulation/xen/xen-3.0.3.ebuild25
1 files changed, 3 insertions, 22 deletions
diff --git a/app-emulation/xen/xen-3.0.3.ebuild b/app-emulation/xen/xen-3.0.3.ebuild
index 8e40557..afcd01a 100644
--- a/app-emulation/xen/xen-3.0.3.ebuild
+++ b/app-emulation/xen/xen-3.0.3.ebuild
@@ -7,14 +7,8 @@ inherit mount-boot flag-o-matic
DESCRIPTION="The Xen virtual machine monitor"
HOMEPAGE="http://xen.sourceforge.net"
XEN_VERSION="3.0.3_0"
-if [[ ${PV} == *_p* ]]; then
- XEN_UNSTABLE="xen-unstable-${PV#*_p}"
- SRC_URI="mirror://gentoo/${XEN_UNSTABLE}.tar.bz2"
- S="${WORKDIR}/${XEN_UNSTABLE}"
-else
- SRC_URI="http://bits.xensource.com/oss-xen/release/${XEN_VERSION/_/-}/src.tgz/xen-${XEN_VERSION}-src.tgz"
- S="${WORKDIR}/xen-${XEN_VERSION}-src"
-fi
+SRC_URI="http://bits.xensource.com/oss-xen/release/${XEN_VERSION/_/-}/src.tgz/xen-${XEN_VERSION}-src.tgz"
+S="${WORKDIR}/xen-${XEN_VERSION}-src"
LICENSE="GPL-2"
SLOT="0"
@@ -78,13 +72,7 @@ src_install() {
local myopt
use pae && myopt="${myopt} pae=y"
- make DESTDIR="${D}" ${myopt} install-xen \
- || die "install failed"
-
- # for upstream change tracking
- if [[ -n ${XEN_UNSTABLE} ]]; then
- dodoc "${S}"/XEN-VERSION
- fi
+ make DESTDIR="${D}" ${myopt} install-xen || die "install failed"
}
pkg_postinst() {
@@ -95,13 +83,6 @@ pkg_postinst() {
einfo "Note: xen tools have been moved to app-emulation/xen-tools;"
einfo "you need to install that package to manage your domains."
- if [[ -n ${XEN_UNSTABLE} ]]; then
- echo
- einfo "This is a snapshot of the xen-unstable tree."
- einfo "Please report bugs in xen itself (and not the packaging) to"
- einfo "bugzilla.xensource.com"
- fi
-
if use pae; then
echo
einfo "This is a PAE build of Xen. It will *only* boot PAE kernels!"