summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2015-11-19 23:51:18 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2015-11-19 23:51:18 +0000
commitf08452b60ccd4e03c721a86c7b1de7823c0eab4e (patch)
tree88f4af5d813b213341120f745e04dc68f0aa1efe
parentdev-python/autobahn: version bump, fix sandbox (diff)
downloadbicatali-f08452b60ccd4e03c721a86c7b1de7823c0eab4e.tar.gz
bicatali-f08452b60ccd4e03c721a86c7b1de7823c0eab4e.tar.bz2
bicatali-f08452b60ccd4e03c721a86c7b1de7823c0eab4e.zip
sci-libs/armadillo: version bump, fix superlu detection
Package-Manager: portage-2.2.25
-rw-r--r--sci-libs/armadillo/Manifest1
-rw-r--r--sci-libs/armadillo/armadillo-6.200.4.ebuild122
-rw-r--r--sci-libs/armadillo/metadata.xml40
3 files changed, 163 insertions, 0 deletions
diff --git a/sci-libs/armadillo/Manifest b/sci-libs/armadillo/Manifest
new file mode 100644
index 0000000..c204c54
--- /dev/null
+++ b/sci-libs/armadillo/Manifest
@@ -0,0 +1 @@
+DIST armadillo-6.200.4.tar.gz 5442156 SHA256 346ecb98cadafcf13493f09c970a2843af58d47a7a801ebce0b5df5b5a39f416 SHA512 9fe261a9b7634f4b1a1adcfab0f4cd850163648a5ead187a978ff2d6ecdc47a73c541e446e96560ea509e7d0fabb8441140b4e95793e332eaf735f2f11154679 WHIRLPOOL a27c097caabadb7d69c93d126f49adb6e36f7a5375f325d8bf72a92affce2dac0fb46e1c3ce15aea83f6f74f0508820103abea69c471443fa9b17eb97445ddb9
diff --git a/sci-libs/armadillo/armadillo-6.200.4.ebuild b/sci-libs/armadillo/armadillo-6.200.4.ebuild
new file mode 100644
index 0000000..852b25b
--- /dev/null
+++ b/sci-libs/armadillo/armadillo-6.200.4.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+CMAKE_IN_SOURCE_BUILD=1
+
+inherit cmake-utils toolchain-funcs multilib eutils
+
+DESCRIPTION="Streamlined C++ linear algebra library"
+HOMEPAGE="http://arma.sourceforge.net/"
+SRC_URI="mirror://sourceforge/arma/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0/6"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="arpack atlas blas debug doc examples hdf5 lapack mkl superlu tbb test"
+REQUIRED_USE="test? ( lapack )"
+
+RDEPEND="
+ dev-libs/boost
+ arpack? ( sci-libs/arpack )
+ atlas? ( sci-libs/atlas[lapack] )
+ blas? ( virtual/blas )
+ lapack? ( virtual/lapack )
+ superlu? ( sci-libs/superlu )
+"
+DEPEND="${RDEPEND}
+ arpack? ( virtual/pkgconfig )
+ atlas? ( virtual/pkgconfig )
+ blas? ( virtual/pkgconfig )
+ hdf5? ( sci-libs/hdf5 )
+ lapack? ( virtual/pkgconfig )
+ mkl? ( sci-libs/mkl )
+ tbb? ( dev-cpp/tbb )"
+PDEPEND="${RDEPEND}
+ hdf5? ( sci-libs/hdf5 )
+ mkl? ( sci-libs/mkl )
+ tbb? ( dev-cpp/tbb )"
+
+src_prepare() {
+ # avoid the automagic cmake macros
+ sed -i -e '/ARMA_Find/d' CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_LIB_DIR="${EPREFIX}/usr/$(get_libdir)"
+ $(cmake-utils_use debug ARMA_EXTRA_DEBUG)
+ $(cmake-utils_use mkl ARMA_USE_MKL_ALLOC)
+ $(cmake-utils_use tbb ARMA_USE_TBB_ALLOC)
+ )
+ if use arpack; then
+ mycmakeargs+=(
+ -DARPACK_FOUND=ON
+ -DARPACK_LIBRARY="$($(tc-getPKG_CONFIG) --libs arpack)"
+ )
+ fi
+ if use atlas; then
+ local c=atlas-cblas l=atlas-clapack
+ $(tc-getPKG_CONFIG) --exists ${c}-threads && c+=-threads
+ $(tc-getPKG_CONFIG) --exists ${l}-threads && l+=-threads
+ mycmakeargs+=(
+ -DCBLAS_FOUND=ON
+ -DCBLAS_INCLUDE_DIR="$($(tc-getPKG_CONFIG) --cflags-only-I ${c} | sed 's/-I//')"
+ -DCBLAS_LIBRARIES="$($(tc-getPKG_CONFIG) --libs ${c})"
+ -DCLAPACK_FOUND=ON
+ -DCLAPACK_INCLUDE_DIR="$($(tc-getPKG_CONFIG) --cflags-only-I ${l} | sed 's/-I//')"
+ -DCLAPACK_LIBRARIES="$($(tc-getPKG_CONFIG) --libs ${l})"
+ )
+ fi
+ if use blas; then
+ mycmakeargs+=(
+ -DBLAS_FOUND=ON
+ -DBLAS_LIBRARIES="$($(tc-getPKG_CONFIG) --libs blas)"
+ )
+ fi
+ if use hdf5; then
+ mycmakeargs+=(
+ -DHDF5_FOUND=ON
+ -DHDF5_LIBRARIES="-lhdf5"
+ )
+ fi
+ if use lapack; then
+ mycmakeargs+=(
+ -DLAPACK_FOUND=ON
+ -DLAPACK_LIBRARIES="$($(tc-getPKG_CONFIG) --libs lapack)"
+ )
+ fi
+ if use superlu; then
+ mycmakeargs+=(
+ -DSuperLU_FOUND=ON
+ -DSuperLU_LIBRARIES="$($(tc-getPKG_CONFIG) --libs superlu)"
+ -DSuperLU_INCLUDE_DIR="$($(tc-getPKG_CONFIG) --cflags-only-I superlu | awk '{print $1}' | sed 's/-I//')"
+ )
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_test() {
+ pushd examples > /dev/null
+ emake \
+ CXXFLAGS="-I../include ${CXXFLAGS} -DARMA_USE_BLAS -DARMA_USE_LAPACK" \
+ EXTRA_LIB_FLAGS="-L.. $($(tc-getPKG_CONFIG) --libs blas lapack)"
+ LD_LIBRARY_PATH="..:${LD_LIBRARY_PATH}" ./example1 || die
+ LD_LIBRARY_PATH="..:${LD_LIBRARY_PATH}" ./example2 || die
+ emake clean
+ popd > /dev/null
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc README.txt
+ use doc && dodoc *pdf && dohtml *html
+ if use examples; then
+ insinto /usr/share/examples/${PF}
+ doins -r examples/*
+ fi
+}
diff --git a/sci-libs/armadillo/metadata.xml b/sci-libs/armadillo/metadata.xml
new file mode 100644
index 0000000..af978f1
--- /dev/null
+++ b/sci-libs/armadillo/metadata.xml
@@ -0,0 +1,40 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ Armadillo is a C++ linear algebra library (matrix maths) aiming
+ towards a good balance between speed and ease of use. Integer,
+ floating point and complex numbers are supported, as well as a
+ subset of trigonometric and statistics functions. Various matrix
+ decompositions are provided through optional integration with LAPACK
+ and ATLAS libraries.
+ A delayed evaluation approach is employed (during compile time) to
+ combine several operations into one and reduce (or eliminate) the
+ need for temporaries. This is accomplished through recursive
+ templates and template meta-programming.
+</longdescription>
+ <use>
+ <flag name="atlas">
+ Link with <pkg>sci-libs/atlas</pkg> libraries for cblas and
+ clapack
+ </flag>
+ <flag name="arpack">
+ Link with <pkg>sci-libs/arpack</pkg> libraries for eigen decomposition
+ </flag>
+ <flag name="mkl">
+ Use matrix allocation from the Intel MKL <pkg>sci-libs/mkl</pkg>
+ </flag>
+ <flag name="tbb">
+ Use matrix allocation from the Threads Building Blocks
+ <pkg>dev-cpp/tbb</pkg>
+ </flag>
+ <flag name="superlu">
+ Use SuperLU for sparse linear equation solving
+ <pkg>sci-libs/superlu</pkg>
+ </flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">arma</remote-id>
+ </upstream>
+</pkgmetadata>