summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCHTEKK <CHTEKK@localhost>2007-03-10 18:21:54 +0000
committerCHTEKK <CHTEKK@localhost>2007-03-10 18:21:54 +0000
commit7747773496151d9671f6b8f33af370ff0906b639 (patch)
tree058e627c21bace00a118bc605f11f987d767971e
parentFix init script. (diff)
downloadchtekk-7747773496151d9671f6b8f33af370ff0906b639.tar.gz
chtekk-7747773496151d9671f6b8f33af370ff0906b639.tar.bz2
chtekk-7747773496151d9671f6b8f33af370ff0906b639.zip
Add SQLite 3.3.13 for testing.
svn path=/; revision=20
-rw-r--r--apps/dev-db/sqlite/Manifest8
-rw-r--r--apps/dev-db/sqlite/files/digest-sqlite-3.3.133
-rw-r--r--apps/dev-db/sqlite/sqlite-3.3.13.ebuild101
3 files changed, 112 insertions, 0 deletions
diff --git a/apps/dev-db/sqlite/Manifest b/apps/dev-db/sqlite/Manifest
new file mode 100644
index 0000000..eff4c9c
--- /dev/null
+++ b/apps/dev-db/sqlite/Manifest
@@ -0,0 +1,8 @@
+DIST sqlite-3.3.13.tar.gz 2054971 RMD160 5ed0c1248db4681349ee89a851fe200ea855fbcd SHA1 405d3f042d64d9ecbb42fff6d4c0dae4a1eeeda2 SHA256 930144d92e91ef7b3a7edbbe768cc539db95c06cf05cb156350f8d35bb56625c
+EBUILD sqlite-3.3.13.ebuild 2308 RMD160 99621866834736de6a078e25cb2d6efaf45404df SHA1 7ccc477c1438e6bf47c09ae7559961f4eec1e87b SHA256 09f405bbc4a92456453cc71fb12d38b4f5195f1161d8d9ab088f89c128311744
+MD5 e08ba4d2014917fc142f626536654709 sqlite-3.3.13.ebuild 2308
+RMD160 99621866834736de6a078e25cb2d6efaf45404df sqlite-3.3.13.ebuild 2308
+SHA256 09f405bbc4a92456453cc71fb12d38b4f5195f1161d8d9ab088f89c128311744 sqlite-3.3.13.ebuild 2308
+MD5 3b6f009d0ee97b4889b62dab551ce08c files/digest-sqlite-3.3.13 244
+RMD160 58529d05c1adb2a4944f0722171f5b059e6b4c7b files/digest-sqlite-3.3.13 244
+SHA256 bcc5af54a28e4aab9ee61500c640b7ec43302836799f0f88ba0604fd4eb0dd77 files/digest-sqlite-3.3.13 244
diff --git a/apps/dev-db/sqlite/files/digest-sqlite-3.3.13 b/apps/dev-db/sqlite/files/digest-sqlite-3.3.13
new file mode 100644
index 0000000..a0eec1d
--- /dev/null
+++ b/apps/dev-db/sqlite/files/digest-sqlite-3.3.13
@@ -0,0 +1,3 @@
+MD5 6b24d9c364215fba82242a86f54e0ad1 sqlite-3.3.13.tar.gz 2054971
+RMD160 5ed0c1248db4681349ee89a851fe200ea855fbcd sqlite-3.3.13.tar.gz 2054971
+SHA256 930144d92e91ef7b3a7edbbe768cc539db95c06cf05cb156350f8d35bb56625c sqlite-3.3.13.tar.gz 2054971
diff --git a/apps/dev-db/sqlite/sqlite-3.3.13.ebuild b/apps/dev-db/sqlite/sqlite-3.3.13.ebuild
new file mode 100644
index 0000000..697665b
--- /dev/null
+++ b/apps/dev-db/sqlite/sqlite-3.3.13.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+inherit eutils alternatives libtool
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+
+DESCRIPTION="SQLite: an SQL Database Engine in a C Library."
+HOMEPAGE="http://www.sqlite.org/"
+SRC_URI="http://www.sqlite.org/${P}.tar.gz"
+LICENSE="as-is"
+SLOT="3"
+IUSE="debug doc nothreadsafe tcl"
+
+DEPEND="doc? ( dev-lang/tcl )
+ tcl? ( dev-lang/tcl )"
+
+RDEPEND="tcl? ( dev-lang/tcl )"
+
+SOURCE="/usr/bin/lemon"
+ALTERNATIVES="${SOURCE}-3 ${SOURCE}-0"
+
+src_unpack() {
+ # test
+ if has test ${FEATURES} ; then
+ if ! has userpriv ${FEATURES} ; then
+ ewarn "The userpriv feature must be enabled to run tests."
+ eerror "Testsuite will not be run."
+ fi
+ if ! use tcl ; then
+ eerror "The tcl USE flag must be enabled to run tests."
+ ewarn "Please note that turning on tcl installs runtime"
+ ewarn "support too."
+ eerror "Testsuite will not be run."
+ fi
+ fi
+
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/sqlite-3.3.3-tcl-fix.patch
+ #epatch "${FILESDIR}"/sqlite-3-test-fix-3.3.4.patch
+
+ #epatch "${FILESDIR}"/sandbox-fix1.patch
+ epatch "${FILESDIR}"/sandbox-fix2.patch
+
+ # Fix broken tests that are not portable to 64bit arches
+ epatch "${FILESDIR}"/sqlite-64bit-test-fix.patch
+ epatch "${FILESDIR}"/sqlite-64bit-test-fix2.patch
+
+ # Respect LDFLAGS wrt bug #156299
+ sed -i -e 's/^LTLINK = .*/& $(LDFLAGS)/' Makefile.in
+
+ elibtoolize
+ epunt_cxx
+}
+
+src_compile() {
+ local myconf="--enable-incore-db --enable-tempdb-in-ram --enable-cross-thread-connections"
+
+ econf ${myconf} \
+ $(use_enable debug) \
+ $(use_enable !nothreadsafe threadsafe) \
+ $(use_enable tcl) \
+ || die "econf failed"
+
+ emake all || die "emake all failed"
+
+ if use doc ; then
+ emake doc || die "emake doc failed"
+ fi
+}
+
+src_test() {
+ if use tcl ; then
+ if has userpriv ${FEATURES} ; then
+ cd "${S}"
+ if use debug ; then
+ emake fulltest || die "some test failed"
+ else
+ emake test || die "some test failed"
+ fi
+ fi
+ fi
+}
+
+src_install () {
+ make \
+ DESTDIR="${D}" \
+ TCLLIBDIR="/usr/$(get_libdir)" \
+ install \
+ || die "make install failed"
+
+ newbin lemon lemon-${SLOT}
+
+ dodoc README VERSION
+ doman sqlite3.1
+
+ use doc && dohtml doc/* art/*.gif
+}