aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/pyrx/pyrx-0.6.ebuild')
-rw-r--r--sci-chemistry/pyrx/pyrx-0.6.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sci-chemistry/pyrx/pyrx-0.6.ebuild b/sci-chemistry/pyrx/pyrx-0.6.ebuild
new file mode 100644
index 0000000..ac01077
--- /dev/null
+++ b/sci-chemistry/pyrx/pyrx-0.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit distutils multilib python eutils
+
+MY_PN="PyRx"
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="GUI for Virtual Screening with AutoDock"
+HOMEPAGE="http://pyrx.sf.net"
+SRC_URI="http://pyrx.scripps.edu/download/${PV}/${MY_P}-Source.zip"
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+RDEPEND=">=sci-chemistry/mgltools-autodocktools-1.5.4
+ dev-python/wxpython
+ sci-libs/vtk
+ dev-python/enthoughtbase
+ dev-python/traits
+ sci-visualization/mayavi
+ dev-python/opal-client
+ >=sci-chemistry/openbabel-2.2.1
+ >=sci-chemistry/autodock-4
+ >=sci-chemistry/autodock-vina-1.1.1"
+DEPEND="${RDEPEND}"
+S=${WORKDIR}
+
+src_prepare() {
+ epatch "${FILESDIR}"/use-external-opal.patch
+}
+
+src_install() {
+ distutils_src_install
+
+ PYVER=$(python_get_version)
+ PYRX="${D}usr/$(get_libdir)/python${PYVER}/site-packages/${MY_PN}"
+ cp -r PyRx/Images/silk_icons \
+ ${PYRX}/Images/ \
+ || die
+ cp PyRx/preferences.ini \
+ ${PYRX}/ \
+ || die
+
+ dodoc README.txt || die
+}