summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-10-20 10:55:50 +0200
committerGilles Dartiguelongue <eva@gentoo.org>2010-10-20 10:55:50 +0200
commit40ec7f5bb8a1338242048215587796c4618b4fb6 (patch)
tree7677620570e6a597cb814efea220ec9de4fd8ed8 /app-office
parentnet-misc/rygel: re-add 0.8 series ebuild (diff)
downloadeva-40ec7f5bb8a1338242048215587796c4618b4fb6.tar.gz
eva-40ec7f5bb8a1338242048215587796c4618b4fb6.tar.bz2
eva-40ec7f5bb8a1338242048215587796c4618b4fb6.zip
app-office/dates: fix build failures
* bump to EAPI 3 * fix build issues with gmake-3.82 * fix build issues with recent evolution-data-server
Diffstat (limited to 'app-office')
-rw-r--r--app-office/dates/Manifest3
-rw-r--r--app-office/dates/dates-0.4.11-r1.ebuild (renamed from app-office/dates/dates-0.4.11.ebuild)13
-rw-r--r--app-office/dates/files/dates-0.4.11-eds-api-usage-fix.patch155
3 files changed, 165 insertions, 6 deletions
diff --git a/app-office/dates/Manifest b/app-office/dates/Manifest
index fff9432..500dae9 100644
--- a/app-office/dates/Manifest
+++ b/app-office/dates/Manifest
@@ -1,4 +1,5 @@
+AUX dates-0.4.11-eds-api-usage-fix.patch 5660 RMD160 5863e0d286badfd856db57303d831c2b9e308983 SHA1 f0bc79ba2af7e570c10151a4aba19fdc2adb23da SHA256 88ab8de4861253be1a8db1be4432f71307fcffa376be95e9495cff021b7ead62
DIST dates-0.4.11.tar.bz2 425726 RMD160 22c2a3d8f51d7addeca8a705537943f3645c1ed4 SHA1 5e5304b29cc89655bd212210c5408cf75c36d491 SHA256 60b0cfe1fa6dee684e255c2a0cd02febafb9d16607ba4b05196e983cd8012c03
-EBUILD dates-0.4.11.ebuild 759 RMD160 c64b89095b751839b0c1d4558a55164a8c4f9d2e SHA1 6dbde4ed91994154f8fdfe3a5340af36db40f1e3 SHA256 0966201b0b8f0104972539b823baa8081f0bec72810fad6aa4cfd136b3a82e42
+EBUILD dates-0.4.11-r1.ebuild 910 RMD160 6552bbc7d7eaacdd07a50bfdffc6067c2c21fd16 SHA1 9deb7182f85b6f43f2446fee9ae74d7a8a95c7b4 SHA256 06a7aaa209f657bf4d3db76a26ecaec0b7152a518d73140902dfc8f1992a8941
MISC ChangeLog 269 RMD160 7a8b61f10b264a46eadf93c5743ab7f2c5f66a32 SHA1 6ce5d76d5717fa8af2a6f1ecf3f946a8e3892721 SHA256 99c745788eb6eb6791529144ea38fa6dbdb83f1c6831879ffdcdb56943c0fd0a
MISC metadata.xml 254 RMD160 d81611ddd88ab740244ac094177b837a9317152e SHA1 1bf06a696d3865a5bf237b557845763fcfcd4468 SHA256 7f16ee4122768d7b7c4c483bdd30592a7a780830009e83fbe781261051774f99
diff --git a/app-office/dates/dates-0.4.11.ebuild b/app-office/dates/dates-0.4.11-r1.ebuild
index 10b04f6..1c54f67 100644
--- a/app-office/dates/dates-0.4.11.ebuild
+++ b/app-office/dates/dates-0.4.11-r1.ebuild
@@ -5,7 +5,7 @@
EAPI="3"
GCONF_DEBUG="yes"
-inherit gnome2
+inherit eutils gnome2
DESCRIPTION="A small, lightweight calendar for Gnome"
HOMEPAGE="http://pimlico-project.org/dates.html"
@@ -16,9 +16,9 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-RDEPEND=">=dev-libs/glib-2.0
- >=x11-libs/gtk+-2.6
- >=gnome-extra/evolution-data-server-1.8
+RDEPEND=">=dev-libs/glib-2:2
+ >=x11-libs/gtk+-2.6:2
+ >=gnome-extra/evolution-data-server-2.32
>=gnome-base/gconf-2"
DEPEND="${RDEPEND}
@@ -31,5 +31,8 @@ src_prepare() {
gnome2_src_prepare
# Fix build with gmake-3.82
- sed 's/^ /\t/g' -i Makefile.am Makefile.in || die
+ sed 's/^ /\t/g' -i Makefile.am Makefile.in || die "sed failed"
+
+ # Fix build against >=evolution-data-server-2.32, upstream #631081
+ epatch "${FILESDIR}/${PN}-0.4.11-eds-api-usage-fix.patch"
}
diff --git a/app-office/dates/files/dates-0.4.11-eds-api-usage-fix.patch b/app-office/dates/files/dates-0.4.11-eds-api-usage-fix.patch
new file mode 100644
index 0000000..e7fce46
--- /dev/null
+++ b/app-office/dates/files/dates-0.4.11-eds-api-usage-fix.patch
@@ -0,0 +1,155 @@
+From 7771e0b3d75b4ba04756d6c6ffc03d644df2db5f Mon Sep 17 00:00:00 2001
+From: Lucas Hermann Negri <lucashnegri@gmail.com>
+Date: Wed, 13 Oct 2010 18:49:20 -0300
+Subject: [PATCH] Replaced the calls to the deprecated functions e_source_{set,get}_color
+ with the new API (e_source_{set,peek}_color_spec).
+
+---
+ src/dates_gtk.c | 40 ++++++++++++----------------------------
+ src/dates_main.c | 2 +-
+ src/dates_view.c | 10 ++++------
+ 3 files changed, 17 insertions(+), 35 deletions(-)
+
+diff --git a/src/dates_gtk.c b/src/dates_gtk.c
+index 78e71bb..403bc25 100644
+--- a/src/dates_gtk.c
++++ b/src/dates_gtk.c
+@@ -1016,7 +1016,6 @@ calendar_do_new_dialog (GtkWindow *parent, DatesData *d)
+ GtkTreeIter iter;
+ GError *error = NULL;
+ const gchar *relative_uri;
+- guint32 new_colour;
+
+ #ifdef WITH_HILDON
+ GdkColor *hildon_color;
+@@ -1055,7 +1054,8 @@ calendar_do_new_dialog (GtkWindow *parent, DatesData *d)
+ source = e_source_new (name, relative_uri);
+
+ #ifdef USE_OWL
+- new_colour = owl_colour_button_get_colour (OWL_COLOUR_BUTTON (color_button));
++ guint32 new_colour = owl_colour_button_get_colour (OWL_COLOUR_BUTTON (color_button));
++ e_source_set_color (source, new_colour);
+ #else
+
+ #ifdef WITH_HILDON
+@@ -1063,17 +1063,11 @@ calendar_do_new_dialog (GtkWindow *parent, DatesData *d)
+ #else
+ gtk_color_button_get_color (GTK_COLOR_BUTTON(color_button), &colour);
+ #endif
+- new_colour = (guint8)(colour.red >> 8);
+- new_colour <<= 8;
+- new_colour |= (guint8)(colour.green >> 8);
+- new_colour <<= 8;
+- new_colour |= (guint8)(colour.blue >> 8);
+- new_colour <<= 8;
++ gchar *n_color = gdk_color_to_string (&colour);
++ e_source_set_color_spec (source, n_color);
++ g_free(n_color);
+ #endif
+
+- /* Set the colour */
+- e_source_set_color (source, new_colour);
+-
+ /* Set the group for the source */
+ e_source_set_group (source, group);
+ e_source_group_add_source (group, source, 0);
+@@ -1169,7 +1163,6 @@ calendar_do_edit_dialog (GtkWindow *parent, ESource *source, DatesData *d)
+ ESourceGroup *group;
+
+ GdkColor colour;
+- guint32 raw_colour;
+
+ const gchar *name = NULL;
+ const gchar *uri = NULL;
+@@ -1335,12 +1328,8 @@ calendar_do_edit_dialog (GtkWindow *parent, ESource *source, DatesData *d)
+ gtk_misc_set_alignment (GTK_MISC (label), 0, 0.5);
+
+ /* Get the colour from the the source */
+- e_source_get_color (source, &raw_colour);
+-
+- /* Munge this into something usable */
+- colour.red = (guint16)(((raw_colour & 0xff0000) >> 16) << 8);
+- colour.green = (guint16)(((raw_colour & 0xff00) >> 8) << 8);
+- colour.blue = (guint16)(((raw_colour & 0xff) << 8));
++ const gchar* spec = e_source_peek_color_spec(source);
++ gdk_color_parse(spec, &colour);
+
+ /* Now we need to allocate the colour */
+ gdk_colormap_alloc_color (gdk_colormap_get_system (), &colour, TRUE, TRUE);
+@@ -1440,26 +1429,21 @@ calendar_do_edit_dialog (GtkWindow *parent, ESource *source, DatesData *d)
+ * Next we need to pack the GDK colour into guint32
+ * for eds
+ */
+- guint32 new_colour = 0;
+
+ GError *error = NULL;
+ #ifdef USE_OWL
+- new_colour = owl_colour_button_get_colour (OWL_COLOUR_BUTTON (color_button));
++ guint32 new_colour = owl_colour_button_get_colour (OWL_COLOUR_BUTTON (color_button));
++ e_source_set_color (source, new_colour);
+ #else
+ #ifdef WITH_HILDON
+ hildon_color_button_get_color (HILDON_COLOR_BUTTON(color_button), &colour);
+ #else
+ gtk_color_button_get_color (GTK_COLOR_BUTTON(color_button), &colour);
+ #endif
+- new_colour = (guint8)(colour.red >> 8);
+- new_colour <<= 8;
+- new_colour |= (guint8)(colour.green >> 8);
+- new_colour <<= 8;
+- new_colour |= (guint8)(colour.blue >> 8);
+- new_colour <<= 8;
++ gchar *n_color = gdk_color_to_string (&colour);
++ e_source_set_color_spec (source, n_color);
++ g_free(n_color);
+ #endif
+- /* Update the colour */
+- e_source_set_color (source, new_colour);
+
+ /* And the name */
+ e_source_set_name (source, (gtk_entry_get_text (GTK_ENTRY (name_entry))));
+diff --git a/src/dates_main.c b/src/dates_main.c
+index ce05fe8..1f7770d 100644
+--- a/src/dates_main.c
++++ b/src/dates_main.c
+@@ -112,7 +112,7 @@ dates_load_calendars (DatesData *d)
+ system_source = e_source_new (_("Personal"), "system");
+
+ /* Default Evolution colour */
+- e_source_set_color (system_source, 0xBECEDD);
++ e_source_set_color_spec (system_source, "#BECEDD");
+
+ /* Set the group for the source and put it in the group */
+ e_source_set_group (system_source, local_group);
+diff --git a/src/dates_view.c b/src/dates_view.c
+index d65db2f..9d28a15 100644
+--- a/src/dates_view.c
++++ b/src/dates_view.c
+@@ -4846,7 +4846,6 @@ dates_view_add_calendar (DatesView *view, ECal *ecal)
+ DatesViewPrivate *priv = DATES_VIEW_GET_PRIVATE (view);
+ DatesViewCalendar *cal;
+ ESource *source;
+- guint32 colour;
+ /* GError *error = NULL;*/
+
+ g_return_if_fail (E_IS_CAL (ecal));
+@@ -4876,12 +4875,11 @@ dates_view_add_calendar (DatesView *view, ECal *ecal)
+ cal->text_gc = gdk_gc_new (
+ GDK_DRAWABLE (priv->main->window));
+
+- if (e_source_get_color (source, &colour)) {
++ const gchar* spec = e_source_peek_color_spec (source);
++ if (spec) {
+ GdkColor gcolour, dgcolour, tgcolour;
+- gcolour.red = ((colour & 0xFF0000) >> 16) * 0x101;
+- gcolour.green = ((colour & 0xFF00) >> 8) * 0x101;
+- gcolour.blue = (colour & 0xFF) * 0x101;
+-
++ gdk_color_parse(spec, &gcolour);
++
+ /* This is simplified sRGB -> LAB conversion; we do not need it
+ * entirely precise, as we are only going to chose between
+ * black or white text based on the L value.
+--
+1.7.3.1
+