summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/freeciv/freeciv-9999.ebuild')
-rw-r--r--games-strategy/freeciv/freeciv-9999.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/games-strategy/freeciv/freeciv-9999.ebuild b/games-strategy/freeciv/freeciv-9999.ebuild
index dfb709a..8bccc10 100644
--- a/games-strategy/freeciv/freeciv-9999.ebuild
+++ b/games-strategy/freeciv/freeciv-9999.ebuild
@@ -4,7 +4,7 @@
inherit eutils games subversion flag-o-matic
-ESVN_REPO_URI="svn://svn.gna.org/svn/freeciv/trunk"
+ESVN_REPO_URI="http://svn.gna.org/svn/freeciv/trunk"
DESCRIPTION="multiplayer strategy game (Civilization Clone)"
HOMEPAGE="http://www.freeciv.org/"
@@ -107,6 +107,7 @@ src_unpack() {
src_compile() {
filter-flags -ftree-vectorize
+ append-flags -fno-tree-vrp
local mysoundconf
local myclient
@@ -133,6 +134,7 @@ src_compile() {
$(use_enable nls) \
$(use_with readline) \
--enable-client=${myclient} \
+ --disable-nls \
${mysoundconf} \
|| die "egamesconf failed"
@@ -158,8 +160,8 @@ src_install() {
# delete civmanual from the GAMES_BINDIR, because it's then useless.
# Note: to have it localized, it should be ran from _postinst, or
# something like that, but then it's a PITA to avoid orphan files...
- ./manual/civmanual || die "civmanual failed"
- dohtml manual*.html || die "dohtml failed"
+ #"${D}/${GAMES_BINDIR}"/civmanual || die "civmanual failed"
+ #dohtml manual*.html || die "dohtml failed"
rm -f "${D}/${GAMES_BINDIR}"/civmanual
fi