summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2021-10-24 07:43:16 +0200
committerHans de Graaff <hans@degraaff.org>2021-10-24 07:43:16 +0200
commit8c225839251b68891d46978cddf45097de555b4c (patch)
tree16e42375df47def43bc895a17fe071bff54c1633 /dev-ruby/request-log-analyzer
parentdev-ruby/rubocop: cleanup (diff)
downloadgraaff-8c225839251b68891d46978cddf45097de555b4c.tar.gz
graaff-8c225839251b68891d46978cddf45097de555b4c.tar.bz2
graaff-8c225839251b68891d46978cddf45097de555b4c.zip
dev-ruby/request-log-analyzer: EAPI 8
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Hans de Graaff <hans@degraaff.org>
Diffstat (limited to 'dev-ruby/request-log-analyzer')
-rw-r--r--dev-ruby/request-log-analyzer/request-log-analyzer-1.13.4-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/request-log-analyzer/request-log-analyzer-1.13.4-r1.ebuild b/dev-ruby/request-log-analyzer/request-log-analyzer-1.13.4-r1.ebuild
new file mode 100644
index 00000000..35502200
--- /dev/null
+++ b/dev-ruby/request-log-analyzer/request-log-analyzer-1.13.4-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="DESIGN.rdoc README.rdoc"
+
+RUBY_FAKEGEM_BINWRAP="request-log-analyzer"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This is a simple command line tool to analyze request log files."
+HOMEPAGE="https://github.com/wvanbergen/request-log-analyzer/wiki"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/activerecord[sqlite] )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+
+ # Drop specs that require a running database
+ rm -f spec/unit/aggregator/database_inserter_spec.rb \
+ spec/unit/database/database_spec.rb || die
+}