summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/stdlib/stdlib-6.ebuild')
-rw-r--r--dev-lua/stdlib/stdlib-6.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/dev-lua/stdlib/stdlib-6.ebuild b/dev-lua/stdlib/stdlib-6.ebuild
index 5517775..e856d71 100644
--- a/dev-lua/stdlib/stdlib-6.ebuild
+++ b/dev-lua/stdlib/stdlib-6.ebuild
@@ -2,6 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
+inherit lua
+
DESCRIPTION="Lua library of modules for common programming tasks"
HOMEPAGE="http://luaforge.net/projects/stdlib/"
SRC_URI="http://luaforge.net/frs/download.php/3584/${P}.tar.gz"
@@ -11,7 +13,8 @@ SLOT="0"
KEYWORDS="~amd64"
IUSE="doc"
-DEPEND="dev-lang/lua"
+DEPEND="dev-lang/lua
+ !dev-lua/getopt"
RDEPEND="${DEPEND}
>=dev-lua/lrexlib-2.2.0"
@@ -22,12 +25,7 @@ src_compile() {
}
src_install() {
- local luaver=
- luaver="$(lua -v 2>&1| cut -d' ' -f2)"
- luaver="${luaver%.*}"
-
- insinto /usr/share/lua/${luaver}
- doins modules/*.lua || die "doins failed"
+ lua_install_module modules/*.lua
if use doc; then
dohtml -r modules/* || die "dohtml failed"