summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhwoarang <hwoarang@gentoo.org>2011-03-14 19:43:01 +0200
committerhwoarang <hwoarang@gentoo.org>2011-03-14 19:43:01 +0200
commit710e1c5c3f8ab7308422c203a6a4a0c7396ee43d (patch)
treec6d0f29a7a0f95dce5894f5321c928d14cd87d2c /dev-util
parentAdd patch from bug #249232. Thanks to Victoria Heisner (diff)
downloadhwoarang-710e1c5c3f8ab7308422c203a6a4a0c7396ee43d.tar.gz
hwoarang-710e1c5c3f8ab7308422c203a6a4a0c7396ee43d.tar.bz2
hwoarang-710e1c5c3f8ab7308422c203a6a4a0c7396ee43d.zip
Initial commit for boost-* 1.46.1 stuff
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/boost-build/Manifest6
-rw-r--r--dev-util/boost-build/boost-build-1.46.1.ebuild111
-rw-r--r--dev-util/boost-build/files/1.35.0-fix_broken_icu_build.patch33
-rw-r--r--dev-util/boost-build/files/CVS/Entries5
-rw-r--r--dev-util/boost-build/files/CVS/Repository1
-rw-r--r--dev-util/boost-build/files/CVS/Root1
-rw-r--r--dev-util/boost-build/files/boost-1.41-fix-mpich2-detection.patch35
-rw-r--r--dev-util/boost-build/files/boost-1.42-fix-mpich2-detection.patch35
-rw-r--r--dev-util/boost-build/files/boost-build-1.42-env-whitespace.patch25
9 files changed, 252 insertions, 0 deletions
diff --git a/dev-util/boost-build/Manifest b/dev-util/boost-build/Manifest
new file mode 100644
index 0000000..1b5c4e3
--- /dev/null
+++ b/dev-util/boost-build/Manifest
@@ -0,0 +1,6 @@
+AUX 1.35.0-fix_broken_icu_build.patch 1752 RMD160 0e7ee05c17d76e29abff915e84181361e4095b89 SHA1 273de1fa957091bf3c0d041f54aec9797810f3cf SHA256 71d858236c47b835947d996d3caf0a1de96ace267140d52dd09594db3a96729d
+AUX boost-1.41-fix-mpich2-detection.patch 1378 RMD160 fd81c6a03dd8bf2d6afdaf3fa4957ee0ff1f6e10 SHA1 bbe5ba6fb554ab89e5fa4649f8a44ad7cd1dfa80 SHA256 8e1adadb1345ff045930bbd1c6d9d6e4b06462de2939021bf9e3a3fe1c9d6100
+AUX boost-1.42-fix-mpich2-detection.patch 1378 RMD160 fd81c6a03dd8bf2d6afdaf3fa4957ee0ff1f6e10 SHA1 bbe5ba6fb554ab89e5fa4649f8a44ad7cd1dfa80 SHA256 8e1adadb1345ff045930bbd1c6d9d6e4b06462de2939021bf9e3a3fe1c9d6100
+AUX boost-build-1.42-env-whitespace.patch 683 RMD160 a96ff55a09a889c5fba0c898cc7d4c2a6d2ef1a5 SHA1 9fd231fc699813df1d3ba78ae95f5f322166ade7 SHA256 52714f45a54cad8c126d5fca8bd5eacc4d746b29df24aaa9d2c55e3694a6f4aa
+DIST boost_1_46_1.tar.bz2 42001335 RMD160 bb43b39f7c4b683b80bafa3042b95e65a242d9c3 SHA1 3ca6e173ec805e5126868d8a03618e587aa26aef SHA256 e1dfbf42b16e5015c46b98e9899c423ca4d04469cbeee05e43ea19236416d883
+EBUILD boost-build-1.46.1.ebuild 3309 RMD160 70f308ca0f6322d6cdd2f95746be7ce0abc610f9 SHA1 511990fc07e64b1941227747c43feedf68d53712 SHA256 889fc96586966fd52db2bfa1cfcf296dda766bf0fc996f0a643f69da07874c06
diff --git a/dev-util/boost-build/boost-build-1.46.1.ebuild b/dev-util/boost-build/boost-build-1.46.1.ebuild
new file mode 100644
index 0000000..6c9c2a4
--- /dev/null
+++ b/dev-util/boost-build/boost-build-1.46.1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.45.0.ebuild,v 1.1 2011/01/06 14:00:10 dev-zero Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic toolchain-funcs versionator
+
+MY_PV=$(replace_all_version_separators _)
+MAJOR_PV="$(replace_all_version_separators _ $(get_version_component_range 1-2))"
+
+DESCRIPTION="A system for large project software construction, which is simple to use and powerful."
+HOMEPAGE="http://www.boost.org/doc/tools/build/index.html"
+SRC_URI="mirror://sourceforge/boost/boost_${MY_PV}.tar.bz2"
+LICENSE="Boost-1.0"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="examples python"
+
+DEPEND="!<dev-libs/boost-1.34.0
+ !<=dev-util/boost-build-1.35.0-r1
+ python? ( dev-lang/python )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/boost_${MY_PV}/tools/build/v2"
+
+src_unpack() {
+ tar xjpf "${DISTDIR}/${A}" boost_${MY_PV}/tools/build/v2 || die "unpacking tar failed"
+}
+
+src_prepare() {
+ # TODO:
+ # epatch "${FILESDIR}/boost-1.42-fix-mpich2-detection.patch"
+
+ cd "${S}/engine"
+ epatch "${FILESDIR}/${PN}-1.42-env-whitespace.patch" # 293652
+
+ # Remove stripping option
+ cd "${S}/engine/src"
+ sed -i -e 's|-s\b||' \
+ build.jam || die "sed failed"
+
+ # Force regeneration
+ rm jambase.c
+
+ # This patch allows us to fully control optimization
+ # and stripping flags when bjam is used as build-system
+ # We simply extend the optimization and debug-symbols feature
+ # with empty dummies called 'none'
+ cd "${S}"
+ sed -i \
+ -e 's/\(off speed space\)/\1 none/' \
+ -e 's/\(debug-symbols : on off\)/\1 none/' \
+ tools/builtin.jam || die "sed failed"
+}
+
+src_compile() {
+ cd engine/src
+ local toolset
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ toolset=darwin
+ else
+ # Using boost's generic toolset here, which respects CC and CFLAGS
+ toolset=cc
+ fi
+
+ append-flags -fno-strict-aliasing
+
+ # For slotting
+ sed -i \
+ -e "s|/usr/share/boost-build|/usr/share/boost-build-${MAJOR_PV}|" \
+ Jambase || die "sed failed"
+
+ # The build.jam file for building bjam using a bootstrapped jam0 ignores
+ # the LDFLAGS env var (bug #209794). We have now two options:
+ # a) change the cc-target definition in build.jam to include separate compile
+ # and link targets to make it use the LDFLAGS var, or
+ # b) a simple dirty workaround by injecting the LDFLAGS in the LIBS env var
+ # (which should not be set by us).
+ if [[ -z "${LDFLAGS}" ]] ; then
+ CC=$(tc-getCC) ./build.sh ${toolset} $(use_with python) \
+ || die "building bjam failed"
+ else
+ LDFLAGS=$(echo ${LDFLAGS}) # 293652
+ LIBS=${LDFLAGS} CC=$(tc-getCC) ./build.sh ${toolset} \
+ $(use_with python) || die "building bjam failed"
+ fi
+}
+
+src_install() {
+ newbin engine/src/bin.*/bjam bjam-${MAJOR_PV}
+
+ cd "${S}"
+ insinto /usr/share/boost-build-${MAJOR_PV}
+ doins -r boost-build.jam bootstrap.jam build-system.jam site-config.jam user-config.jam \
+ build kernel options tools util || die
+
+ dodoc changes.txt hacking.txt release_procedure.txt \
+ notes/build_dir_option.txt notes/relative_source_paths.txt
+
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r example
+ fi
+}
+
+src_test() {
+ cd engine/test
+ ./test.sh || die "tests failed"
+}
diff --git a/dev-util/boost-build/files/1.35.0-fix_broken_icu_build.patch b/dev-util/boost-build/files/1.35.0-fix_broken_icu_build.patch
new file mode 100644
index 0000000..b461105
--- /dev/null
+++ b/dev-util/boost-build/files/1.35.0-fix_broken_icu_build.patch
@@ -0,0 +1,33 @@
+--- trunk/tools/build/v2/build/targets.jam (revision 45072)
++++ trunk/tools/build/v2/build/targets.jam (revision 45245)
+@@ -1170,5 +1170,5 @@
+ ECHO [ targets.indent ] "Building target '$(fn)'" ;
+ targets.increase-indent ;
+- ECHO [ targets.indent ] "Build request: " [ $(property-set).raw ] ;
++ ECHO [ targets.indent ] "Build request: " $(property-set) [ $(property-set).raw ] ;
+ local cf = [ build-system.command-line-free-features ] ;
+ ECHO [ targets.indent ] "Command line free features: " [ $(cf).raw ] ;
+@@ -1275,5 +1275,14 @@
+ # case we don't want any diagnostic. In the former case, we need
+ # diagnostics. FIXME
+- self.generated.$(property-set) = $(rproperties) ;
++
++ # If this target fails to build, add <build>no to properties
++ # to cause any parent target to fail to build. Except that it
++ # - does not work now, since we check for <build>no only in
++ # common properties, but not in properties that came from
++ # dependencies
++ # - it's not clear if that's a good idea anyway. The alias
++ # target, for example, should not fail to build if a dependency
++ # fails.
++ self.generated.$(property-set) = [ property-set.create <build>no ] ;
+ }
+ }
+@@ -1283,4 +1292,7 @@
+ {
+ ECHO [ targets.indent ] "Already built" ;
++ local ur = $(self.generated.$(property-set)) ;
++ ur = $(ur[0]) ;
++ ECHO [ targets.indent ] " Usage requirements " [ $(ur).raw ] ;
+ }
+ }
diff --git a/dev-util/boost-build/files/CVS/Entries b/dev-util/boost-build/files/CVS/Entries
new file mode 100644
index 0000000..8edebe8
--- /dev/null
+++ b/dev-util/boost-build/files/CVS/Entries
@@ -0,0 +1,5 @@
+/1.35.0-fix_broken_icu_build.patch/1.1/Thu Jun 5 20:04:08 2008//
+/boost-1.41-fix-mpich2-detection.patch/1.1/Wed Dec 2 15:25:01 2009//
+/boost-1.42-fix-mpich2-detection.patch/1.1/Wed Mar 3 12:32:09 2010//
+/boost-build-1.42-env-whitespace.patch/1.1/Sat Aug 14 06:35:54 2010//
+D
diff --git a/dev-util/boost-build/files/CVS/Repository b/dev-util/boost-build/files/CVS/Repository
new file mode 100644
index 0000000..28efdd8
--- /dev/null
+++ b/dev-util/boost-build/files/CVS/Repository
@@ -0,0 +1 @@
+gentoo-x86/dev-util/boost-build/files
diff --git a/dev-util/boost-build/files/CVS/Root b/dev-util/boost-build/files/CVS/Root
new file mode 100644
index 0000000..94453ca
--- /dev/null
+++ b/dev-util/boost-build/files/CVS/Root
@@ -0,0 +1 @@
+:ext:hwoarang@cvs.gentoo.org:/var/cvsroot
diff --git a/dev-util/boost-build/files/boost-1.41-fix-mpich2-detection.patch b/dev-util/boost-build/files/boost-1.41-fix-mpich2-detection.patch
new file mode 100644
index 0000000..d3bd646
--- /dev/null
+++ b/dev-util/boost-build/files/boost-1.41-fix-mpich2-detection.patch
@@ -0,0 +1,35 @@
+Index: tools/build/v2/tools/mpi.jam
+===================================================================
+--- tools/build/v2/tools/mpi.jam (revision 57744)
++++ tools/build/v2/tools/mpi.jam (working copy)
+@@ -156,14 +156,27 @@
+ # into a feature.
+ local match = [ MATCH "^(-.)(.*)" : $(cmdline) ] ;
+ local matched ;
+- if $(match) && $(match[2]) {
++ if $(match) && $(match[2]) {
+ local prefix = $(match[1]) ;
+ if $(feature_kinds$(prefix)) {
+ local name = $(feature_kinds$(prefix)) ;
+ local add = [ add_feature $(prefix) $(name) $(cmdline) ] ;
+
+ if $(add) {
+- result += $(add[1]) ;
++
++ if $(add[1]) = <find-shared-library>pthread
++ {
++ # Uhm. It's not really nice that this MPI implementation
++ # uses -lpthread as opposed to -pthread. We do want to
++ # set <threading>multi, instead of -lpthread.
++ result += "<threading>multi" ;
++ MPI_EXTRA_REQUIREMENTS += "<threading>multi" ;
++ }
++ else
++ {
++ result += $(add[1]) ;
++ }
++
+ cmdline = $(add[2]) ;
+ matched = yes ;
+ }
+
diff --git a/dev-util/boost-build/files/boost-1.42-fix-mpich2-detection.patch b/dev-util/boost-build/files/boost-1.42-fix-mpich2-detection.patch
new file mode 100644
index 0000000..d3bd646
--- /dev/null
+++ b/dev-util/boost-build/files/boost-1.42-fix-mpich2-detection.patch
@@ -0,0 +1,35 @@
+Index: tools/build/v2/tools/mpi.jam
+===================================================================
+--- tools/build/v2/tools/mpi.jam (revision 57744)
++++ tools/build/v2/tools/mpi.jam (working copy)
+@@ -156,14 +156,27 @@
+ # into a feature.
+ local match = [ MATCH "^(-.)(.*)" : $(cmdline) ] ;
+ local matched ;
+- if $(match) && $(match[2]) {
++ if $(match) && $(match[2]) {
+ local prefix = $(match[1]) ;
+ if $(feature_kinds$(prefix)) {
+ local name = $(feature_kinds$(prefix)) ;
+ local add = [ add_feature $(prefix) $(name) $(cmdline) ] ;
+
+ if $(add) {
+- result += $(add[1]) ;
++
++ if $(add[1]) = <find-shared-library>pthread
++ {
++ # Uhm. It's not really nice that this MPI implementation
++ # uses -lpthread as opposed to -pthread. We do want to
++ # set <threading>multi, instead of -lpthread.
++ result += "<threading>multi" ;
++ MPI_EXTRA_REQUIREMENTS += "<threading>multi" ;
++ }
++ else
++ {
++ result += $(add[1]) ;
++ }
++
+ cmdline = $(add[2]) ;
+ matched = yes ;
+ }
+
diff --git a/dev-util/boost-build/files/boost-build-1.42-env-whitespace.patch b/dev-util/boost-build/files/boost-build-1.42-env-whitespace.patch
new file mode 100644
index 0000000..681de7a
--- /dev/null
+++ b/dev-util/boost-build/files/boost-build-1.42-env-whitespace.patch
@@ -0,0 +1,25 @@
+diff --git a/tools/jam/src/build.jam b/tools/jam/src/build.jam
+index e30e854..7b397a3 100644
+--- a/tools/jam/src/build.jam
++++ b/tools/jam/src/build.jam
+@@ -2,6 +2,20 @@
+ #~ Distributed under the Boost Software License, Version 1.0.
+ #~ (See accompanying file LICENSE_1_0.txt or http://www.boost.org/LICENSE_1_0.txt)
+
++# Clean env vars of any "extra" empty values.
++for local v in ARGV CC CFLAGS
++{
++ local values ;
++ for local x in $($(v))
++ {
++ if $(x) != ""
++ {
++ values += $(x) ;
++ }
++ }
++ $(v) = $(values) ;
++}
++
+ # Platform related specifics.
+ if $(NT) { rule .path { return "$(<:J=\\)" ; } ./ = "/" ; }
+ else if $(OS2) { rule .path { return "$(<:J=\\)" ; } ./ = "/" ; }