summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin F. Quinn <kevquinn@gentoo.org>2006-12-17 16:23:57 +0000
committerKevin F. Quinn <kevquinn@gentoo.org>2006-12-17 16:23:57 +0000
commit9c45eb754ef714a5576c5b1f9b96b1cd5be10374 (patch)
treea0bb9020c4698740be9ed5a66d97d38ce1f66203
parentFix for ia64/sparc nondef pie patch (diff)
downloadkevquinn-9c45eb754ef714a5576c5b1f9b96b1cd5be10374.tar.gz
kevquinn-9c45eb754ef714a5576c5b1f9b96b1cd5be10374.tar.bz2
kevquinn-9c45eb754ef714a5576c5b1f9b96b1cd5be10374.zip
fixup crtstuff some more
svn path=/; revision=118
-rw-r--r--hardened/toolchain/eclass/toolchain.eclass4
1 files changed, 3 insertions, 1 deletions
diff --git a/hardened/toolchain/eclass/toolchain.eclass b/hardened/toolchain/eclass/toolchain.eclass
index 20fbd1c..161cd72 100644
--- a/hardened/toolchain/eclass/toolchain.eclass
+++ b/hardened/toolchain/eclass/toolchain.eclass
@@ -2159,8 +2159,10 @@ do_gcc_PIE_patches() {
epatch "${WORKDIR}"/piepatch/nondef
# Force crt{begin,end}.o to be built normally; for all linux
# If Gentoo/FreeBSD ever want hardened, need to do the same to t-freebsd
- sed -e '/^CRTSTUFF_T_CFLAGS_S =/iCRTSTUFF_T_CFLAGS = $(CRTSTUFF_T_CFLAGS) -fno-PIE' \
+ sed -e '/^CRTSTUFF_T_CFLAGS_S =/iCRTSTUFF_T_CFLAGS = -fno-PIE' \
-i "${S}"/gcc/config/t-linux
+ sed -e '/^CRTSTUFF_T_CFLAGS =/iCRTSTUFF_T_CFLAGS = -fno-PIE' \
+ -i "${S}"/gcc/Makefile.in
# adds default pie support (rs6000 too) if DEFAULT_PIE[_SSP] is defined
want_minispecs ||
EPATCH_MULTI_MSG="Applying default pie patches ..." \