summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-shells/bash/files/bash-3.2-parallel-build.patch')
-rw-r--r--app-shells/bash/files/bash-3.2-parallel-build.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/app-shells/bash/files/bash-3.2-parallel-build.patch b/app-shells/bash/files/bash-3.2-parallel-build.patch
new file mode 100644
index 0000000..0ee0491
--- /dev/null
+++ b/app-shells/bash/files/bash-3.2-parallel-build.patch
@@ -0,0 +1,16 @@
+http://bugs.gentoo.org/189671
+http://lists.gnu.org/archive/html/bug-bash/2007-08/msg00081.html
+
+--- bash-3.2/Makefile.in
++++ bash-3.2/Makefile.in
+@@ -584,7 +584,9 @@
+ @( { test "${RL_LIBDIR}" = "${libdir}" && exit 0; } || \
+ cd ${RL_LIBDIR} && $(MAKE) $(MFLAGS) libreadline.a) || exit 1
+
+-$(HISTORY_LIBRARY): config.h $(HISTORY_SOURCE)
++# prevent parallel build race conditions in the lib/readline/ subdir
++# by depending on libreadline.a when applicable
++$(HISTORY_LIBRARY): config.h $(HISTORY_SOURCE) $(READLINE_DEP)
+ @echo making $@ in ${HIST_LIBDIR}
+ @( { test "${HIST_LIBDIR}" = "${libdir}" && exit 0; } || \
+ cd ${HIST_LIBDIR} && $(MAKE) $(MFLAGS) libhistory.a) || exit 1